Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Question Input Consumption problems

Discussion in 'Input System' started by reinhardt92, Feb 8, 2023.

  1. reinhardt92

    reinhardt92

    Joined:
    Mar 7, 2021
    Posts:
    5
    In my game you can fall through the ground by pressing S (modifier) + Space (binding) at the same time. However, for some reason it stopped working after I updated Unity a few versions ago. After doing some research, I realized that a lot of people had their modifers + binding affected too, and someone said that, in order for that to work as before, you had to check 'Enable Input Consumption', as seen below:

    upload_2023-2-8_20-55-34.png

    However, after checking that option, for some reason I cannot move my player anymore. I tried everything I could think of and still, nothing.

    Here's my actions and properties:
    upload_2023-2-8_20-53-37.png

    Has anyone come across this situation? This doesn't make sense to me.

    Thank you.
     
  2. John_Leorid

    John_Leorid

    Joined:
    Nov 5, 2012
    Posts:
    658
    Composites are broken. Once you add them, you either get a lot of errors every time you save the InputActionAsset or Composites such as WASD don't work. Changing and saving the InputActionAsset, so it throws Erros and then restarting the Editor worked for me. But now I have to do this every single time I change the controls.