Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Official Increasing requirements for Unity 2023.2 Intel Editor & Runtime to macOS 11

Discussion in 'macOS' started by pixelsprite_unity, May 2, 2023.

  1. pixelsprite_unity

    pixelsprite_unity

    Unity Technologies

    Joined:
    Sep 22, 2022
    Posts:
    15
    Hello folks,

    I’m Maria, Senior Technical Product Manager with the Apple Platform team.

    From Unity 2023.2, we will update the minimum specifications for macOS to Big Sur 11+. The new macOS system requirements will be:
    • Intel Editor: 11+ Big Sur (from Mojave 10.14+ )
    • Silicon Editor: 11+ Big Sur (unchanged)
    • Unity Player: 11+ Big Sur (from Mojave 10.14+ )
    What does this mean for me?
    If you are developing on an Intel-based Macs and want to upgrade to Unity 2023, your machine’s operating system will need to be running Big Sur or later. On Unity versions after 2023.2, the macOS Intel Editor and Standalone Players will not run on previous macOS versions.

    Why are you making this change?
    Updating our minimum requirements allows us to focus on areas and features that matter most for this platform, especially those that are used by the majority of our developers.

    Additionally, security updates and support from Apple for these older operating systems have already stopped after September 2022/2021 for 10.15 and 10.14 respectively.

    Finally, we expect this to impact a low number of developers and end-users on machines that can’t upgrade to macOS 11, around 1%. This is projected to drop even lower in 2023-2024 as Apple continues to ramp up its shift to Apple Silicon.

    Will this affect older Unity versions?
    No.

    Unity 2021 LTS and Unity 2022 LTS will continue to support your projects on their existing requirements at pre-Big Sur levels. This change only applies to Unity 2023 onwards.
    Here is the support you can expect for these versions based on your license:

    Unity 2021
    Requirements
    High Sierra 10.13+ (Intel editor) / Big Sur 11.0 (Apple Silicon Editor) / High Sierra 10.13+ (Runtime)
    Support
    • Personal/Pro/Plus: 2024
    • Enterprise: 2025
    Unity 2022
    Requirements

    Mojave 10.14+ (Intel editor) / Big Sur 11.0 (Apple Silicon Editor) / Mojave 10.14+ (Runtime)
    Support
    • Personal/Pro/Plus: 2025
    • Enterprise: 2026
    How do I know which version of macOS I’m currently using?
    From the Apple icon, click on ‘About this Mac.’

    Will my machine be able to upgrade?
    The majority of Apple machines released after mid-2013 will be able to upgrade to Big Sur.

    Thank you,

    Maria

    Apple Platform Team
     
    Last edited: May 9, 2023
    DevDunk likes this.
  2. bnmguy

    bnmguy

    Joined:
    Oct 31, 2020
    Posts:
    136
    Maria,

    Please learn the name of the OS. It is macOS, not OSX. It hasn't been OSX since 2015! How can we trust Unity to get anything right when, after 8 years, it still doesn't know the name of the OSes it supports? (well, the macOS editor is hardly supported I guess, since it crashes every 2 mins).
     
    adslitw likes this.
  3. pixelsprite_unity

    pixelsprite_unity

    Unity Technologies

    Joined:
    Sep 22, 2022
    Posts:
    15
    Hey @bnmguy thank you for the feedback - I have updated the post to use the name more consistently.

    Please do send us any issues you may be encountering with the macOS editor through our bug report system so that we can support you.
     
  4. Deleted User

    Deleted User

    Guest


    Hi Maria,

    could you please take a look at the issues that I am facing here? https://forum.unity.com/threads/apple-silicon-support-through-the-unity-hub.1222971/page-2

    Thank you in advance.
     
    Lars-Steenhoff likes this.
  5. Lars-Steenhoff

    Lars-Steenhoff

    Joined:
    Aug 7, 2007
    Posts:
    3,510
    Deleted User likes this.
  6. MZEBRA

    MZEBRA

    Joined:
    Jul 11, 2020
    Posts:
    3
    Last edited: Jan 18, 2024