Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Increasing bounced light?

Discussion in 'Global Illumination' started by HemiMG, Aug 15, 2015.

  1. HemiMG

    HemiMG

    Joined:
    Jan 17, 2014
    Posts:
    911
    My Global Illumination woes continue as I try to get this game lit the way I want. In the image below, you can see a room, with a fair amount of windows, and a directional light shining right into them. In real life, the room would be fairly well lit. I thought that Enlighten would bounce the light around the room and light it up, but that appears to not be the case. The scene looks pretty much the same even if I turn indirect light and bounce boost all the way to the maximum. Of course, with them maxed out, the scene looks absolutely horrible when the lights are turned on. Turning them off doesn't have a dramatic effect either. There are times when I bake the GI and the whole level is lit up when the lights are out, but that is an error of some sort because it happens even in completely closed off rooms. Baking again usually fixes it.

    The directional light is realtime, because I want my exit doors to be able to open and the shadows to change. I did try baking it though, figuring not being able to open the doors would be a smaller annoyance that not having light in a room during the middle of the day. That didn't help either.

    I'm going to download CryEngine and Unreal and see if I can get the level recreated in one of those fairly quickly. But I really, really don't want to lose all of the work I've done in Unity and eat the money I've spent on assets for this game already. I feel like I'm missing some simple step somewhere that is causing all of my problems. If anyone has any idea how to get that room to light up, please tell me.

    Screenshot (29).png
     
  2. HemiMG

    HemiMG

    Joined:
    Jan 17, 2014
    Posts:
    911
    Well, this is one that I was able to figure out. I didn't realize that Enlighten doesn't recognize transparency. Turning off Lightmap Static on the glass fixed the issue. I've still got a lot of playing around to do to get results that I'm pleased with, but at least my room is lighting up now.

    Now if I could just figure out the half a zillion other problems I'm having with Enlighten I might forget that I downloaded Unreal last night.
     
  3. fffMalzbier

    fffMalzbier

    Joined:
    Jun 14, 2011
    Posts:
    3,276
    You can say to Enlighten that specific objects are treated as Transparent objects.
    You have to create a Lightmap Parameters asset (Assets -> Create -> Lightmap Parameters).
    There is a option called "Is Transparent".
    Lightmap Parameters asset can be selected under the lighting window -> Objects -> Advanced Parameters. ( you should have your objects selected to to this.
     
  4. HemiMG

    HemiMG

    Joined:
    Jan 17, 2014
    Posts:
    911
    Yeah, I saw that after I turned them off of lightmap static. Does it make a difference which way you do it? Things are looking okay now. I just still can't get rid of all the crazy seams I am getting. There are some that are there with no GI or reflection probes at all, some that appear when reflection probes are in the scene, and some that appear when GI is on. I'm assuming it's the same issue causing all of them, but I don't know how to fix it other than making all of the hallways one mesh with a mitred corner instead of butting the walls of rooms together.

    I don't see anyway around that though, because it turns out that Unreal is much, much worse than Unity with lighting.