Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Bug (IN-21006) Hub CLI Installs Incorrect Android Dependencies

Discussion in '2022.2 Beta' started by Andrew010110, Nov 21, 2022.

  1. Andrew010110

    Andrew010110

    Joined:
    Oct 8, 2022
    Posts:
    18
    I’ve noticed that with the recent changes to Android tool versions, the Unity Hub CLI doesn’t install the correct versions. I’ve had this reported as a bug for a month now with no response. I’ve also brought this up on the Hub forum but that doesn’t seem to be monitored by Unity employees to the same degree as this forum so I wanted to bring this to light here as 2022.2.0f1 is releasing very soon. This is a major issue as CI pipelines and other scripted installs rely on the CLI to install Unity and the necessary dependencies.