Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  4. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Improve Sprite Quality

Discussion in '2D' started by path14, Jun 14, 2018.

  1. path14

    path14

    Joined:
    Apr 9, 2017
    Posts:
    74
    Hey all. I've struggled with this before this current lil' project and never really solved it. I've scoured the web and changed all the settings in hopes to improve sprite quality in my UI, but at a loss.

    I'm currently publishing into WebGL at 1024x768 on a macbook pro (retina).

    I have no import compression, filter mode point, no mip maps, 32 PPU, canvas scaler to screensize (1024x768 reference), orthographic size 12, and my png's are exported from Adobe Illustrator with 300ppi. The only thing that seems to make a difference is hiking the resolution up really high in the canvas settings in WebGL, making the sprites much larger with improved quality, but I want to keep it in a single web page so that's not going to work.

    What am I missing / doing wrong? I've attached two images where the edges of the sprites are just not sharp enough. It's driving me insane....

    Screen Shot 2018-06-14 at 8.58.12 AM.png Screen Shot 2018-06-14 at 7.39.44 AM.png
     
  2. Hosnkobf

    Hosnkobf

    Joined:
    Aug 23, 2016
    Posts:
    392
    everything jumping in my mind is already setup correctly by you (no import compression, filter mode point, no mip maps).

    Only one idea left: Maybe it helps if you check "Pixel Perfect" in your Canvas.
     
  3. path14

    path14

    Joined:
    Apr 9, 2017
    Posts:
    74
    That's not it either....I think it's a resolution issue, but it may just be in Unity Mac...
     
  4. Hosnkobf

    Hosnkobf

    Joined:
    Aug 23, 2016
    Posts:
    392
    maybe you can plug in a non-retina display to your mac and see if it makes a difference...

    Edit: maybe it is also something related to the used graphics framework... you can try to start unity in Open GL mode or Metal mode with the command line arguments
    -force-glcore
    /
    -force-gfx-metal
    (see here)
     
  5. Narendraom

    Narendraom

    Joined:
    Jul 8, 2015
    Posts:
    34
    I have same issue with Sprites on iPhone. How can i resolve it?
     
  6. fabiopicchi

    fabiopicchi

    Joined:
    Jan 22, 2016
    Posts:
    10
    I have been working with a Pixel Perfect 2D game for a while now and have stumbled across many issues with image quality.

    Your settings are very similar to mine. I don't know if that's the answer to your problem but you could try fiddling with Quality Settings under Edit > Project Settings > Quality Settings. I had to turn off Anti Alias and Anisotropic Textures and set Texture Quality to Full Res otherwise the pixel colours were messed up.
     
    Narendraom likes this.
  7. path14

    path14

    Joined:
    Apr 9, 2017
    Posts:
    74
    I'll give it a try. Thanks for the input! :)
     
  8. barskey

    barskey

    Joined:
    Nov 19, 2017
    Posts:
    165
    Is your Max Size setting larger than the imported Sprite Resolution? Try setting it to larger than whichever side of your sprite is longer. In other words, if your sprite is 800x600, set it to 1024.