Search Unity

  1. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  2. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  3. Participate with students all over the world and build projects to teach people. Join now!
    Dismiss Notice
  4. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  6. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Importing Blender animation - move away pivot.

Discussion in 'Animation' started by _Valerio_, Dec 7, 2018 at 3:57 PM.

  1. _Valerio_

    _Valerio_

    Joined:
    Apr 27, 2016
    Posts:
    1
    I have some animations made in blender. Some of them imported fine, but some of them move away pivot(or skeleton). Imagine - when you run rotate animation, your model doesn't rotate itself, but rotates around pivot.
    I import animations from blender file. All animations are in one file, use same mesh and rig.
    I use mecanim, humanoid rig. Rig is fine, and in T-pose.

    See screenshots:
    Animation that imported wrong:
    in blender
    Capture.PNG

    In unity. As you can see pivot(center) and ground is somewhere in another universe. Changing position properties for animation doesn't help.
    Capture1.PNG

    Correct imported animation:
    in blender
    Capture3.PNG
    In unity, so the pivot is at the center of the model, and model placed on the ground.
    Capture5.PNG
    I have already lost two days, trying to find the reason, but i even don't know where problem is - in unity or in blender.

    interest info - when you save blender file - Blender(or unity, hmmm) creates "Default Take" animation, that is same as opened action(animation) in blender, and when that animation is "Default take" - it works fine. Capture4.PNG

    But it is not a solution cause i have many wrong imported animations.

    So, if you have the same issue, or have any ideas - please help me, cause i am getting crazy.

    PS: I know my English is awesome, so if you didn't understand my explanation please ask me)
     
    Last edited: Dec 7, 2018 at 4:04 PM