Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Official Important update: Google Play Billing Library v4

Discussion in 'Unity IAP' started by Yannick_Denis, Jul 28, 2022.

Thread Status:
Not open for further replies.
  1. Yannick_Denis

    Yannick_Denis

    Unity Technologies

    Joined:
    Feb 21, 2022
    Posts:
    141
    The In-App Purchasing SDK version 4.4.0 now uses Google Play Billing Library v4 for the Google Play Store.

    Google Play Billing Library v3 is going to be deprecated soon.
    Starting on August 2, 2022, all new apps on the Google Play Store will require this update.
    By November 1, 2022, all updates to existing apps will require this update.

    For more details regarding this deprecation: https://developer.android.com/google/play/billing/deprecation-faq
     
  2. VasiliyChe

    VasiliyChe

    Joined:
    Dec 7, 2020
    Posts:
    12
    Hi Yannick_Denis!

    We're using Unity 2019 LTS, the maximum available version of the IAP package is 4.1.5

    Are there any plans to add GPBL v4 support for Unity 2019 LTS?

    Thanks
     
  3. Yannick_Denis

    Yannick_Denis

    Unity Technologies

    Joined:
    Feb 21, 2022
    Posts:
    141
    Hello VasiliyChe,

    Unfortunately, there are no plans to add GPBL v4 support for Unity 2019 LTS.
    Since 4.2.0-pre.1, the minimum Unity Editor version we support is 2020.3.
     
  4. LandonC

    LandonC

    Joined:
    Dec 20, 2012
    Posts:
    83
    Can I know if this means that anyone not using 2020.3 will have to use it now since there is no support for 2020.3 & below? My entire game breaks if I use 2020.3
     
  5. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Correct, you would need to use Unity 2020.3 or above. Unity 2018 and 2019 are no longer supported.
     
  6. MaxWang0

    MaxWang0

    Joined:
    Jun 12, 2020
    Posts:
    1
    Google has updated Billing Library 5, whether billing 4 can be used and billed normally
     
  7. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Correct, we will be using GPBL v5 in an upcoming release later this year. The v4 version can be used until then.
     
  8. ASHStudioinc

    ASHStudioinc

    Joined:
    Jan 31, 2019
    Posts:
    6
    Is there a way I can use IAP 4 in 2018 as If i am upgrading my project breaks and things I have to do all over again
     
  9. ASHStudioinc

    ASHStudioinc

    Joined:
    Jan 31, 2019
    Posts:
    6
    Is there a way we can use iap 4 still in old versions
     
  10. sanabelapps

    sanabelapps

    Joined:
    Dec 26, 2017
    Posts:
    2
    what if i added the new billing-4.0.0.aar file in the project and it will be added to the gradle.build file. Will that fix the issue?
     
  11. Grazer2

    Grazer2

    Joined:
    Jun 20, 2011
    Posts:
    74
    The In-App Purchasing SDK version 4.4.0 shows up in my Package Manager (Unity 2020.3.32) but is not marked as Verified. Wondering why that is. Is it still in a beta-phase? When will it be marked as Verified? Thanks
     
  12. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Verified only means it has been vetted. It is not beta, it is production-quality and tested.
     
  13. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Sorry no, please see my earlier post. We use APIs that are not present in earlier versions of the Editor. Locking this thread now.
     
Thread Status:
Not open for further replies.