Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Immersive headset (Samsung Odyssey+) - app "installs" but launches as 2D view

Discussion in 'Windows Mixed Reality' started by bsawyer, Oct 23, 2019.

  1. bsawyer

    bsawyer

    Joined:
    May 6, 2014
    Posts:
    34
    The details:
    • Unity 2019.2.9
    • MixedRealityToolkit 2.1.0
    • Yes, Virtual Reality Supported is checked in PlayerSettings
    • Yes, Windows Mixed Reality SDK is added (MRTK ensures correct settings at startup)
    • Unity build process runs fine (generates UWP solution)
    • I can open the generated solution in VS2017 or VS2019 and build and deploy
    • The game appears successfully installed as it shows up in my Start Menu
    However when launching the game that I just built and installed, it only behaves as a 2D app, there's no VR/immersion at all. Launching it directly does not force the MR Portal to open. If I put on the headset first and browse to the app within that virtual room space, the app appears as a floating 2D view.

    Documentation has stagnated greatly for WMR Immersive Displays (if it was ever truly there in the first place) with the impending release of the HoloLens 2 and I sort of get that, but I can't find ANYTHING online that explains what I'm missing.

    Any help?
     
  2. joejo

    joejo

    Unity Technologies

    Joined:
    May 26, 2016
    Posts:
    560
    Do you have None as the first item in your list of SDKs/Devices in player settings?
     
  3. bsawyer

    bsawyer

    Joined:
    May 6, 2014
    Posts:
    34
    No, the only item in the list is "Windows Mixed Reality". Depth Format: 24-bit depth, "Enable Depth Buffer Sharing": true
     
  4. joejo

    joejo

    Unity Technologies

    Joined:
    May 26, 2016
    Posts:
    560
    Are there any errors in the player log?
     
  5. bsawyer

    bsawyer

    Joined:
    May 6, 2014
    Posts:
    34
    Hm, I just went digging to find the UnityPlayer.log (in AppData\Local\Packages\<my app package\TempState) and noticed the bold line here at the top of the file:

    That seems like smoke to me. Bear in mind no errors occur at any stage of the build that I can notice.
     
  6. joejo

    joejo

    Unity Technologies

    Joined:
    May 26, 2016
    Posts:
    560
    Make sure that remoting is not enabled in XR Settings.
     
  7. bsawyer

    bsawyer

    Joined:
    May 6, 2014
    Posts:
    34
    AH, THANK YOU! I don't know why that box got checked if it's not by default, but unchecking it solved the issue for me.