Search Unity

Image Effects / Post processing problem

Discussion in 'Editor & General Support' started by TheMonkeysaur, Sep 4, 2017.

  1. TheMonkeysaur

    TheMonkeysaur

    Joined:
    May 2, 2017
    Posts:
    46
    Hi,

    I have been struggling with a problem for afew days where reloading my project results in problems with image effects.

    I have created a test project and created one brick object, and set it's material to emission on, and I have turned bloom on in the cameras post processing file.

    At this point, when I place my glowing brick in the scene everything works fine and as it should.

    If I save and reload the project, the image effects remain visable in the scene view, but in the project view they are no longer there.

    The camera's HDR setting doesn't seem to have any effect, and I have also noticed that the loss of image effects in my game view is the same loss of image effects I get in my scene view when I use the Motion Vectors debug view in my post processing profile.

    At present in my test project I have 1 object with 1 material, the Post Processing Stack and one post processing profile with bloom turned on (1.3 HDR). When I save and reload after creating this project I lose all image effects in Game view (but not scene view) and I cannot seem to get them working again.

    Thanks for any help anyone can give.

    *****************************************

    EDIT: I have gone as far as to install 2017, and the same thing happens, except now it happens to both scene and game view. No problems with a new project, but as soon as it is saved and reloaded all image effects stop working.

    ****************************************

    EDIT2: I also just attempted a build from a new project in which the effects were working, the effects are not working in the build, and as soon as the build is complete the effects are no longer working in the editor either.

    I am using bloom with HDR emission material. When having this problem, if I turn Bloom on and off I can see that it is there, but it's very faint, almost impossible to see (where before it was very obvious) and when I turn emission off on my material the object using it goes dark, so emission is working, but it no longer seems to use HDR.

    My game relies on emissive effects to distinguish object so I'm really stuck here and pulling my hair out. I've tried clean reinstalls and removing Unity AppData but nothing seems to help.

    Thanks.


    ******************************************

    EDIT3: This does not seem to happen if I open a 3D project, Even using a 2D sprite in the 3D project the emission/bloom is working after a save and reload.

    I have now changed the Editor settings in my project so that it defaults to 3D, and now when I load my (2D) game everything is working as it should.

    Does anyone have any idea what has happened here any why?

    Thanks.
     
    Last edited: Sep 4, 2017
  2. TheMonkeysaur

    TheMonkeysaur

    Joined:
    May 2, 2017
    Posts:
    46
    I have now submitted a bug report to Unity.
     
  3. SVC-Games

    SVC-Games

    Joined:
    May 21, 2013
    Posts:
    112
    I'm having the same issue here. Starting a project as 3D work as expected buy creating a similar scene in my 2D project yoelds the same results: No Bloom in game view but visible in Scene view... Do you have the number of the issue to upvote it?
     
  4. inewland

    inewland

    Joined:
    Dec 6, 2012
    Posts:
    20
    Yes I have found the same result as SVC-Games. Starting a 2D project causes the Game View to not render Bloom + HDR effects with Emission. Going to Edit -> Project Settings -> Editor and setting Default Behavior Mode to 3D and restarting Unity fixes the issue.
     
  5. Khaeops

    Khaeops

    Joined:
    Dec 28, 2014
    Posts:
    18
    Can be resolved. Edit > Project Settings > Graphics. Enable 'Use HDR' where it is not. This setting was disabled for all my tiers when I was building to PC, using a project created in Unity 2018.1.b10.
     
unityunity