Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

Help Wanted I'm having trouble with MLAPI

Discussion in 'Netcode for GameObjects' started by F8CHILLYT, Jun 26, 2021.

  1. F8CHILLYT

    F8CHILLYT

    Joined:
    Sep 21, 2019
    Posts:
    4
    I decided to try my hand at the MLAPI preview and came across 2 errors that make it impossible to use.

    Error 1: when using MLAPI with the latest version of the unity editor, I'm faced with this error:

    ILPostProcessorRunner ILPostProcessorRunner caught the following exception while processing arguments:

    Error 2: when using MLAPI with the latest LTS version of the unity editor, I'm faced with this error:

    (0,0): error System.IO.FileNotFoundException:

    Neither of these errors have exceptions, or arguments, and both appear as soon as the MLAPI package is enabled.
     
  2. luke-unity

    luke-unity

    Unity Technologies

    Joined:
    Sep 30, 2020
    Posts:
    179
    Could you tell us the exact Unity versions you were using? So the errors appear immediately in the console after installing the package and they don't go away if you try to clear the package correct?

    Is it possible that your project name might have some special characters in it. Other users have encountered similar issues with MLAPI if they did.
     
  3. F8CHILLYT

    F8CHILLYT

    Joined:
    Sep 21, 2019
    Posts:
    4
    I am using 2021.1.12f1. The errors appear immediately upon installation of the package, but once the package is removed, so are the errors. There are no special characters.
     
  4. F8CHILLYT

    F8CHILLYT

    Joined:
    Sep 21, 2019
    Posts:
    4
    The other version is 2020.3.12f1
     
unityunity