Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Question I'm doing a 2D platformer course on coursera, does it need the latest 2020 version?

Discussion in 'Getting Started' started by RichAllen2021, Aug 17, 2022.

  1. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    Above.

    I tried the course yesterday, I downloaded and installed the Package files, but there were errors given.

    And no, I cannot provide a screenshot of the error page.

    The version of Unity I currently I have is 2020.23 I think.
     
  2. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    What version do they recommend? They should specify in the videos. How far did you get? Otherwise, you would want to contact your instructor. Please show a screenshot of the errors (or copy-paste the exact errors, not sure why you cannot provide this necessary information) and the specific version of Unity that you are using (you should know this, you installed it), we may be able to offer suggestions. Are you still on Linux? They may not have tested the course on Linux systems.
     
  3. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    I'm installing the latest 2020 version as I type, I'll report back if there's any errors after tea.
     
  4. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    Screenshot from 2022-08-17 18-38-24.png

    Here's a pic of the errors, note the stuff in red at the bottom of the screen.
     
  5. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Got it. Which video is prompting you to install this package? Do you have a link to the package files? You'll want to confirm with the instructor what the preferred version of Unity would be. It could be a Linux issue also.
     
  6. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
  7. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    Screenshot from 2022-08-17 19-16-23.png

    Same error on 2020.37 version, it could be a Linux issue, I'll contact the tutor.

    I've just Tweeted the tutor, I'll let you know if he responds.
     
    Last edited: Aug 17, 2022
    JeffDUnity3D likes this.
  8. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Can you share the package download link in a private message? I'll try it here too
     
  9. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    Check your inbox Jeff :)

    I've just replied to your PM, check your inbox.
     
    Last edited: Aug 17, 2022
  10. mgear

    mgear

    Joined:
    Aug 3, 2010
    Posts:
    8,071
    also try enabling new Input System (and importing Input System from package manager)
    that last image says some error about it?
     
    RichAllen2021 likes this.
  11. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    I'll try that tomorrow.

    Thanks :)
     
  12. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    The only link I have to the download of the Package files is the one I sent by PM last night.

    I've Tweeted the tutor but he's unlikely to even acknowledge my message.
     
  13. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    You sent a web page link not a download link. There should be downlink on that page. I'm not enrolled in the course so I can't view the web page.
     
  14. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    Not my fault or problem.

    I do not have the download link, it is on the webpage.
     
  15. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Yes, I'm fairly certain you didn't set the permissions on that page, I'm not sure what you are referring to. It's not your fault but it is your problem because we can't help you! Please provide the download link on that webpage. I don't have access to the page because I'm not enrolled in the course. What is the package file name? Is there a link on the web page to the download?
     
  16. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
  17. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
  18. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    @RichAllen2021 Please remove the public link and follow my directions. This is for a private class you are taking.
     
  19. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    Also, I think I know what the problem might be, the files are out of date (dated last year) and do not contain the InputManager file, hence the error messages.
     
  20. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    You are correct. Adding the Input System and 2D Tilemap Editor makes the errors go away. I suspect the tutorial context would mention this, but at least this works.
     
  21. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    I'll have a look over the weekend, I don't have access to Unity at the moment due to being on my Chrome OS Desktop at the Flat, my Ubuntu box (a supported OS) is at my Parents'.
     
  22. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    I printed out the next steps last night, something about adding the input via the Unity registry, and then the 2D Tilemaps.

    I'll have a play with it when I get back to my Parents' later.

    I've managed to install the input manager.

    I just need to do the Tilemaps part of the tutorial next.
     
    Last edited: Aug 21, 2022
  23. RichAllen2021

    RichAllen2021

    Joined:
    Jul 19, 2016
    Posts:
    651
    I started the Tilemaps bit last night, I'll do some more this afternoon, well there's not much on TV so it'll keep me busy.
     
unityunity