Search Unity

IL2CPP Mac not working when downloaded through hub

Discussion in 'Unity Hub' started by dxmachina, Feb 17, 2018.

  1. dxmachina

    dxmachina

    Joined:
    Jul 4, 2012
    Posts:
    60
    Hi Guys,

    When using the dedicated installer for the 2018.1b7 release IL2CPP DOES work for Mac Standalone.

    When downloaded through the hub the build window reports IL2CPP missing (though it is installed as a component).
     
  2. cassandraL

    cassandraL

    Unity Technologies

    Joined:
    Dec 7, 2017
    Posts:
    108
    Hi!
    Thank you for pointing this issue to us. We are trying to repro it.
    Are you on mac or on Windows?
     
  3. dxmachina

    dxmachina

    Joined:
    Jul 4, 2012
    Posts:
    60
    MacOS 10.13.3. Same situation with b8. Let me know if I can be of any help.
     
  4. cassandraL

    cassandraL

    Unity Technologies

    Joined:
    Dec 7, 2017
    Posts:
    108
    @dxmachina I was able to repro. We will see how we can fix this!
    Thanks for the heads up!
     
    Charles_Beauchemin likes this.
  5. Charles_Beauchemin

    Charles_Beauchemin

    Unity Technologies

    Joined:
    Jan 18, 2017
    Posts:
    358
    @dxmachina We just pushed a fix to production. You'll need to restart your hub (using Quit and relaunching it) to update its data. After that, if you re-install the build from the hub, it should be working. Thanks for your help on identifying this issue!
     
  6. dxmachina

    dxmachina

    Joined:
    Jul 4, 2012
    Posts:
    60
    Charles_Beauchemin likes this.