Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

If anyone is having visual studio shell 2010 invalid license data. reinstall is required

Discussion in 'Scripting' started by ramonsantana, Feb 18, 2015.

  1. ramonsantana

    ramonsantana

    Joined:
    Feb 18, 2015
    Posts:
    3
    I found a fix since the other fix was not working...
    This problem is caused by installing Microsoft SQL Server.
    Here is how to fix it:

    Use regedit go to HKEY_CLASSES_ROOT and look for Visual Studio.DTE
    Since i have Visual Studio 2015 CTP installed i have 3 DTE, one is VisualStudio.DTE, the other Visual StudioDTE.10.0 and VisualStudio.DTE.14.0
    Go to VisualStudio.DTE.14.0 ( or whatever version of Visual studio you have installed) and click CLSID. Copy the Default (Double click Default and Copy the key inside), now go back to Visua Studio.DTE and double click the Default there and paste the key you just copied.
    Almost there
    On VisualStudio.DTE go to CurVer and double click the key there to Edit it. Change the 10.0 in the end to 12.0 or 13.0 or 14.0, depending on what version of Visual Studio you have and you are done

    Congratulations, no more persky visual studio shell 2010 invalid license data. reinstall is required

    Just tested and it works.

    Enjoy it!!!!
     
    Last edited: Feb 18, 2015
    Kenmeister likes this.
  2. ArnoStalgik

    ArnoStalgik

    Joined:
    Aug 16, 2015
    Posts:
    1
    Hi,

    I just discovered your post today and I just want to thank you !

    I found a lot of 'solutions' for this problem but none worked.

    Yours just work perfectly and just take a few seconds, thank you again. I can finally use VS !!!
     
  3. Kenmeister

    Kenmeister

    Joined:
    Apr 8, 2016
    Posts:
    1
    Excellent answer, worked for me too. I ran into this after I installed SQL server 2012 management studio - that install created the registry key issue. Versions of SQL Server Management studio prior to 2016 uses VS 2010 for it's visual editor. Unity obviously looks at this registry key in the Visual Studio initiation. I believe this issue is taken care of in SQL server 2016.