Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

I have a blank inspector panel

Discussion in 'Getting Started' started by pp3, Jan 12, 2017.

  1. pp3

    pp3

    Joined:
    Jan 12, 2017
    Posts:
    1
    I am trying to follow the Roll A Ball tutorial on this site. I have created the project and added a plane(ground). The next step was click on the gear icon in the inspector panel but my Inspector panel is blank! what can I do?
    Thanks,
    Paul
     
  2. Ryiah

    Ryiah

    Joined:
    Oct 11, 2012
    Posts:
    15,961
    Check to make sure you have the appropriate object selected. A blank inspector usually means nothing is selected.
     
    jimyang6888 and Kiwasi like this.
  3. mgear

    mgear

    Joined:
    Aug 3, 2010
    Posts:
    6,138
    its also possible to have folder/file selected in project window, and had accidentally pressed the lock icon..
    then inspector is almost empty too.

    check that the lock is unlocked
    upload_2017-1-12_11-43-56.png
     
    yogeshbhatt, SparkxP1 and Kiwasi like this.
  4. patrbr126

    patrbr126

    Joined:
    Feb 12, 2017
    Posts:
    4
    Sorry to be a pain but this is my first go at this and I have the same problem - how do I make sure that I have the appropriate object selected - I have clicked both right and left on to various areas of the project and no inspector tab comes up and no gear icon? can you help - thanks.
     
  5. Kiwasi

    Kiwasi

    Joined:
    Dec 5, 2013
    Posts:
    16,723
    Can you show us a screen shot?

    Normally just clicking on the GameObject of interest in the hierarchy window will bring it up in the inspector.
     
  6. patrbr126

    patrbr126

    Joined:
    Feb 12, 2017
    Posts:
    4
  7. patrbr126

    patrbr126

    Joined:
    Feb 12, 2017
    Posts:
    4
    Thanks for having a look at this.
     
  8. Ryiah

    Ryiah

    Joined:
    Oct 11, 2012
    Posts:
    15,961
    You're just missing the Inspector tab. It's trivial to add it back. Click Window then click Inspector (or hit CTRL-3 or CMD-3 depending on whether you're on Windows or macOS). After the Inspector window has opened click and drag the tab from that window to where you want the Inspector to be.
     
  9. Kiwasi

    Kiwasi

    Joined:
    Dec 5, 2013
    Posts:
    16,723
    Lol. That's a new one I didn't think of.

    You can also use the layout dropdown in the top right to set things back to one of the defaults.
     
    ZaydJardien and patrbr126 like this.
  10. Ryiah

    Ryiah

    Joined:
    Oct 11, 2012
    Posts:
    15,961
    Right, but I feel like if they removed it they were likely setting up a custom layout (after all the Inspector panel is there by default in every layout) and want it to be laid out a certain way.
     
    patrbr126 likes this.
  11. patrbr126

    patrbr126

    Joined:
    Feb 12, 2017
    Posts:
    4
    Folks thank you both so much I have now got the inspector tab which is great news - I can now get on with this tomorrow before work - Big Thanks!:)
     
  12. Seych

    Seych

    Joined:
    Aug 10, 2018
    Posts:
    1
    Thanks so much everyone was so helpful :)
     
  13. y2k_elder

    y2k_elder

    Joined:
    Apr 18, 2020
    Posts:
    1
    I had this problem too, first time user, running tutorials.

    Inspector tab was blank for everything I clicked, not even the properties specified in the tutorial were preset. I clicked on the "..." widget and "Normal" was selected. I selected "Debugging" and a whole bunch of stuff showed up. I re-selected "Normal", and then there were properties that were not there before, the tab looks correct now. I had to do this every time I selected something, switch to "Debug" and back to "Normal", which was unworkable. I even closed the tutorial tabs, closed and re-opened Unity Hub and the problem persisted.

    When I closed the Inspector tab and re-opened from the Window menu, it started working ok.

    I suspect that the Tutorial is to blame, and that it is a bug. I think the Tutorial is trying to simplify the panel but instead is causing a fubar condition. So if you are using the tutorials and have this problem, try to just close and re-add the tab.
     
    N8N8N8, Kvalder89 and engri like this.
  14. narraboth

    narraboth

    Joined:
    Apr 18, 2015
    Posts:
    2
    THANK YOU! It was driving me crazy!
    By the way I wasn't working on the tutorial, but a different project. It could be a new bug.
     
  15. colorido3835

    colorido3835

    Joined:
    Nov 18, 2019
    Posts:
    1
    Has someone reported it yet?
     
  16. dgromanis

    dgromanis

    Joined:
    May 29, 2020
    Posts:
    1
    I'm having a similar problem but the solutions above aren't working - I'm in the Animator clicking on a Grounded state but nothing is appearing in the Inspector window. Like, nothing at all. Any ideas? I'm using Unity 2019.3.15f1 Personal for Mac. Very annoying, as the tutorial I'm following requires me to change a selection in the Inspector :(
     

    Attached Files:

    pjohnstone and SoftChainKD like this.
  17. medialabgames

    medialabgames

    Joined:
    Jul 5, 2020
    Posts:
    1
    I have exactly the same problem as dgromanis above. (PC Unity 2019.4.2f1) Nothing in the inspector panel (ie. no parameters, blank no matter what I select) and nothing I do will make it work. I too am trying to follow a game jam official You Tube tutorial. To be honest I really think the whole tutorial side is a mess. There are many things that are wrong; menu items do not match the tutorials, locations of things are completely wrong (most likely referring to older versions) and a lot of me progressing has been complete guesswork. I am a developer by trade so it isn't as though I've never seen a computer before.
     
    dgromanis and pjohnstone like this.
  18. pjohnstone

    pjohnstone

    Joined:
    Jul 6, 2018
    Posts:
    1
    I'm having the same issue as @dgromanis and @medialabgames: When selecting an animation state in the Animator window the Inspector window is completely empty. Unity 2020.2.0a17

    In the Inspector window, both Normal and Debug mode is empty, and switching back and forth between the two does not make any difference.
     

    Attached Files:

  19. JamesInGreerSC

    JamesInGreerSC

    Joined:
    Jul 25, 2020
    Posts:
    1
    Same issue as above. Animator has a completely blank inspector. Nothing tried has worked :(
     
  20. pbritton

    pbritton

    Joined:
    Nov 14, 2016
    Posts:
    74
    I have encountered the same problem. It works with some clips but others are blank.

    I solved my problem by changing this flag to one.
    m_ObjectHideFlags: 1
    It was three previous. This was done in a text editor. I located the AnimatorState and change the property. I am not entirely sure if this fix could break other things.
     
    Last edited: Jul 28, 2020
  21. Reahreic

    Reahreic

    Joined:
    Mar 23, 2011
    Posts:
    139
    This happens to me often when i'm using a custom editor or property drawer. (More-so for scriptable objects than any other object type) The inspector just fails to draw. It's seemingly random and takes a few clicks on other items then back to the original item to bring it back. That or switch to the lighting tab then back to the inspector tab.

    No errors, logs or warnings are ever thrown and often the content of the object hasn't been changed either. I've never been able to identify a cause.
     
  22. N8N8N8

    N8N8N8

    Joined:
    Apr 14, 2020
    Posts:
    4
    This was my issue, thanks!
     
unityunity