Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Humanoid avatar just "sits" in ground, any way to make the avatar not do that?

Discussion in 'Animation' started by motif_nostalgia, Jun 4, 2020.

  1. motif_nostalgia

    motif_nostalgia

    Joined:
    Apr 8, 2019
    Posts:
    2
    I recently spent about 5 hours searching around on the forums for a solution, but all of them have to do with imported animations. Here's the context: I made an avatar from scratch, in blender, and rigged it with no animations, then imported to unity. This meant that where you would normally see import options for animations, there was none. When I set the rig to humanoid in the rig panel, I didn't change anything in the configure menu, everything was already properly set up. My issue currently is that whenever I try to set up an idle animation, my character's hips sink below the "ground"(the position of the actual gameobject), and that means that trying to use Unity's foot IK results in what's shown below. Is there any way to move the character's hips up or a way to make the animation based on the ground, so I can use unity's built-in foot IK? upload_2020-6-3_19-38-34.png upload_2020-6-3_19-39-32.png
     
  2. Kybernetik

    Kybernetik

    Joined:
    Jan 3, 2013
    Posts:
    2,583
    That's the pose a Humanoid rig goes into when no animation is playing. The most common cause I've seen is if you try to play a Generic animation on a Humanoid rig or if the state in your Animator Controller doesn't actually have the animation assigned.