Search Unity

huge problems with 2018.3 on Mac OS X with Android builds...

Discussion in 'Android' started by Muckel, Mar 2, 2019.

  1. Muckel

    Muckel

    Joined:
    Mar 26, 2009
    Posts:
    438
    hello,
    just to let the users know... there are still plenty of bug's in Unity 2018.3
    1. Android builds are broken on device!
    they build fine with graddle but not with internal...
    om Android device the graddle build doesn't work nor start....
    updated the SDK too... NDK too....

    if i build the same on 2018.2.20 all works fine and nooooo Problems...
    all apps running without issues etc....

    i read all the problems here and the blah blah from some unity boy's here lol
    we are aware of it... our best people working on it... sure but why do you release beta software without warning???

    don't get me wrong but i know unity much better than most people here... i'm user since beginning when it was Mac only ....
    but now things have changed a lot... and unity does not care anymore about us... you see and notice it everywhere... look here into the forums with so many open questions since years the forums are dead for me...
    also the graddle and IL2CPP taking much longer to build now... the result is not better and the apk has double size than before...
    and also what is this for a bullshit output :
    App_Name.symbols.zip > around 1gb extra with each build

    don't know but Unity3d 2018.3 is not ready for public projects... what a mess now
    it all becomes more and more disappointed here...

    @ all Mac User... it's time to move on me think... emails and bug's get not answered nor fixed...
    Mac user got totally ignored...
    2018.2.20 seams to be the last version that works ...

    M.:(
     
  2. angelochu7

    angelochu7

    Joined:
    Nov 14, 2018
    Posts:
    26
    Hello Muckel, I experienced just the opposite.

    Unity version: 2018.3.6f1
    OS: MacOS Mojave

    I can build the Android apk using "Internal (deprecated)" but the app experience some issue which I don't have in iOS build.

    Moreover, I can export the Android Studio project using option "Gradle" but there are many errors while building like the following:



    I hope someone will drop me a line if they have a solution.
     
    Muckel likes this.
  3. Muckel

    Muckel

    Joined:
    Mar 26, 2009
    Posts:
    438
    hello,
    well in 2018.2.20 i can build everything without issues...
    i can use mono or IL2CPP... build with internal or graddle... no problem...
    but if i do the same with 2018.3.x build for Android doesn't work... non of them...
    do a blank project and build... nooo .....
    all sek and ndk mono up to date...
    testet now on 3 machines...
    @Unity3D what's up with that mess... no more testing on Mac ??
    are we now beta tester also in final builds...?
    really don't like the direction you've taken...
    VR & AR was also not so huge you've promised ... like i said before that happen...
    better put the resources into better engine that runs faster and not slower on older mobiles and PC...
    M.:Tiphat:

    Bildschirmfoto 2019-03-03 um 07.42.55.png Bildschirmfoto 2019-03-03 um 07.43.17.png
     
  4. Muckel

    Muckel

    Joined:
    Mar 26, 2009
    Posts:
    438
    error message...
    so nobody from Unity3D cares...

    it really hurts to see what roadmap Unity had taken... and noooooo support anymore... only making more money it's the only goal now.... good that there is a epic game engine who cares ;-)
    and much faster on mobile too...
    long term i can say good buy ... Unity3D like we did with Flash before...
    huge marketing big words... and @ the end... nothing special....
    if i build with Unity3d very. 4.6 my Mobile App it runs twice so fast as with actual builds...
    @Unity3D we are not your beta tester! Do your homework! We pay you for!!!!

    very very disappointed here
    M.
     
    Last edited: Mar 10, 2019
  5. dominykasm

    dominykasm

    Unity Technologies

    Joined:
    May 27, 2018
    Posts:
    66
    Could you share the errors that you get in Unity when building with Gradle?
     
  6. dominykasm

    dominykasm

    Unity Technologies

    Joined:
    May 27, 2018
    Posts:
    66
    The Internal build system is old and deprecated and it's already removed in Unity 2019.1.
    It's recommended to use Gradle. Could you list the errors and the overall problems that you're facing when building with Gradle?
     
  7. Muckel

    Muckel

    Joined:
    Mar 26, 2009
    Posts:
    438
    hello,
    well can now confirm that the last 2019.1.0f2 works without issues on the same project...
    nothing changed on the setup or files...
    2019.1.0f2 looks and works much better now!
    well done
    M.
     
  8. jamesk5

    jamesk5

    Joined:
    Nov 26, 2012
    Posts:
    15
    hey @dominykasm please help!

    I'm having the same issue with Unity 2018.4. I was hoping to release my game using LTS instead of the tech stream.

    Note, I'm not having these issues in the editor or with iOS builds.

    What's going on?

    On a side note, I upgraded from Unity 2018.4.0f1 to 2018.4.1f1. No improvement. For some reason cloud build does not list 2018.4.1f1 as a build target, only 0f1, so I'm not able to build with the same version as my editor. :(
     
    Last edited: May 30, 2019
  9. aa_lique

    aa_lique

    Joined:
    Aug 6, 2015
    Posts:
    3
    Hi I just found this message and wanted to know what are the issues w/Mac OS.
     
unityunity