Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Bug Hub v3.8.0 won't download editors or modules

Discussion in 'Unity Hub' started by IanWellock, May 8, 2024.

  1. IanWellock

    IanWellock

    Joined:
    Nov 2, 2019
    Posts:
    5
    MacBook Pro i9 fully patched and up to date: been using the machine for years with Unity.

    For the last couple of months, no new Editor or Module will download. They all get down to around 80-99%, and then stop. They stay at that position for as long as I care to leave them: 12 hours is the record.

    I can cancel the download and restart, and the same thing happens, although the percentage can vary.

    No other Internet/download issues anywhere, and I can download these things from the Download Archive with no problem (but they won't install, which is a separate problem).

    I literally can't install a new Editor or a new Module. At all.
     
  2. Jawadov

    Jawadov

    Joined:
    Jan 3, 2016
    Posts:
    8
    Same problem here !!!!! Download failed: Validation Failed
     
  3. Dragonic1

    Dragonic1

    Joined:
    May 13, 2024
    Posts:
    1
    I'm running it on a Surface Laptop 4, and I downloaded just the editor, ONCE But without any of the documentation or build support and it couldn't even run learning stuff. Any idea how to fix this? I've looked at other forums but none were for 3.8.0
     
  4. IanWellock

    IanWellock

    Joined:
    Nov 2, 2019
    Posts:
    5
    Bump. Still can't install Unity at all. Still every single download gets most of the way and hangs. No comment, no reaction, no help.
     
  5. PaulInAtlGA

    PaulInAtlGA

    Joined:
    Jan 3, 2013
    Posts:
    1
    Same problem here. How can they ignore this critical problem?
     
  6. IanWellock

    IanWellock

    Joined:
    Nov 2, 2019
    Posts:
    5
    I reported the bug and they told me to (basically) turn it off then on again.

    Nothing helped, I replied telling them that, and again they’ve gone quiet.