Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Feedback Hub running in background

Discussion in 'Unity Hub' started by grizzly, Jun 6, 2019.

  1. grizzly

    grizzly

    Joined:
    Dec 5, 2012
    Posts:
    357
    I note that the Hub runs silently in the background when the Editor's launched directly (or via a shortcut). Can we please have the ability to disable this behaviour? It's a waste of system resources when not required.

    Thanks.
     
    Westland, Novack and sbstnzmr like this.
  2. HugoZink

    HugoZink

    Joined:
    Mar 4, 2018
    Posts:
    13
    Several months later and this still isn't an option.

    The Unity Hub is forced upon us and we don't even get an option to disable this invasive behavior.
     
    Westland, Novack and grizzly like this.
  3. grizzly

    grizzly

    Joined:
    Dec 5, 2012
    Posts:
    357
    Indeed. Such a simple request to fall on deaf ears.

    Perhaps there are more sinister reasons for this Hub Key Logging :eek:
     
    Novack likes this.
  4. pbritton

    pbritton

    Joined:
    Nov 14, 2016
    Posts:
    157
    This problems still persists. :mad:
     
  5. LaurynasLubys

    LaurynasLubys

    Joined:
    Mar 7, 2012
    Posts:
    80
    Same problem. I experience huge lag in full screen mode in editor, whenever Unity Hub is running in the background. Strange bug, but must be fixed.
     
  6. sbstnzmr

    sbstnzmr

    Joined:
    Aug 2, 2019
    Posts:
    1
    This is basically the behavior of malware. The dafualt behavior of the standard ui header X icon means close the damn app. If you change a default behavior the very least you can do is let your users change it back. This seems little but enforcing thins like this is what let's me doubt you in general as a company and what I as a user mean to you. You should not get to decide how my system handles the standard ui icons and which applications I want to allow to just minimize and permanently run in the background.
     
    Novack and shellshaffer169 like this.
  7. CheerlessSnake

    CheerlessSnake

    Joined:
    Aug 8, 2020
    Posts:
    1
    Unity Hub still runs in the background. I always have to close it from the system tray.
     
  8. pbritton

    pbritton

    Joined:
    Nov 14, 2016
    Posts:
    157
    Almost two years later and we still have this problem.
     
    shellshaffer169 likes this.
  9. shellshaffer169

    shellshaffer169

    Joined:
    Sep 18, 2021
    Posts:
    1
    And here it is May, 2022 and still no resolution...
     
  10. PenguinWarlord

    PenguinWarlord

    Joined:
    Jul 21, 2019
    Posts:
    1
    This also a series problem in a multi user environment.

    If you forget to close the Hub background process for one user, and then try and open the Hub for an separate user, it crashes showing a blank screen. Frustratingly you then need to reinstall Hub to get it to work again.

    I would really rather have the option to just not have hub run in the background.
     
  11. organiclogic

    organiclogic

    Joined:
    Nov 22, 2020
    Posts:
    2
    Yeah this is a bit obnoxious, especially since the system tray has been removed from many linux distros. The tray can added back through means of "extensions", but if its not available out of the box, its not getting installed. There should be an option in the context menu of unity hub to Quit (meaning close down parent process) rather than just "Close" (Hide). You'd never even know it were running unless you checked the System Monitor or "ps auxf | grep unity". System trays cannot be relied on as a means to close down an application. For awhile i was running UnityHub from a Bash prompt, which would let me kill the process simply by pressing CTRL+C.

    From an outsiders perspective, it may seem nit-picky, but there are members of the community that take security/privacy/operational features seriously and feel unsettled when services continue to run after an "intent" to shutdown is issued. I don't believe any of this is nefarious, but it would be nice if applications wouldn't continue to use resources after they're no longer needed for a given session. To be honest, it is the single reason why Windows 7 was my last Microsoft OS. Wayyy to much background noise and network talk when I'm not even using the machine. Apps need to obey the end user, not the other way around. Linux has been that breath of fresh air that I've craved for years.

    For now, its just a force kill of the root unityhub process when I'm done using it. Would very much like to see this fixed. Minor, but subjectively important features on an otherwise amazing product.

    Edit: Running unityhub from the command prompt =will= terminate unityhub when you press CTRL+C in the command line window after you're done. I was getting false processes from a bad search term. You don't get this option if you run it from the desktop icon. Seems the easiest route since I don't have a system tray on this version of Gnome. I've deleted my desktop launch icon to avoid accidentally using the app the way it was intended XD. Sucks to have to jump through these kinds of hoops to close down a service, but linux and all of its variants is a hard target.
     
    Last edited: Jul 27, 2022
    kdchabuk likes this.
  12. Novack

    Novack

    Joined:
    Oct 28, 2009
    Posts:
    842
    Ended up here by googling how to prevent the Hub to be launched along with the editor. There is another similar feedback suggestion here.

    I tried to bypass the Hub by manually launching Unity editor from the command line as indicated here, but that seems to work no more.

    Some suggested to unninstall the Hub, but I'd like to keep the hub installed as an option, just not to launch it when I dont want to. So frustrating they spoonfeed us like this.
     
  13. dev11223

    dev11223

    Joined:
    Feb 6, 2022
    Posts:
    3
    Almost 4 years but still have to deal with the same issue.
     
    Novack likes this.