Search Unity

  1. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  4. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Hub Installation fails every time

Discussion in 'Unity Hub' started by sebas77, Jun 23, 2018.

  1. sebas77

    sebas77

    Joined:
    Nov 4, 2011
    Posts:
    591
    0.18 installation cannot be completed. It kept on failing as long as I kept using the C:\Program Files\ folder. I had to install on another hard drive to make it work again.

    P.S.: running as administrator didn't change the issue.
     
  2. cassandraL

    cassandraL

    Unity Technologies

    Joined:
    Dec 7, 2017
    Posts:
    42
    Hi,
    sorry to hear you had trouble installing the Hub.

    Were you trying a fresh install or to update the Hub (from, say, 0.17 to 0.18)?
    Also, which version of Windows are you on?
     
  3. sebas77

    sebas77

    Joined:
    Nov 4, 2011
    Posts:
    591
    Update it, win 10, as far as I understood many users encountered the issue. Does it sound right to you?
     
  4. cassandraL

    cassandraL

    Unity Technologies

    Joined:
    Dec 7, 2017
    Posts:
    42
    Hi,
    we are still trying to reproduce the issue.
    Could you give us more details, please?
    - How did you update the Hub? (By clicking the blue message in the app or reinstalling manually?)
    - Which context are you on: home computer, business computer or school computer? Is there a single or multiple users on your OS?

    Thanks a lot for the feedback!
     
  5. sebas77

    sebas77

    Joined:
    Nov 4, 2011
    Posts:
    591
  6. sebas77

    sebas77

    Joined:
    Nov 4, 2011
    Posts:
    591
    it seems that the problem persists, even with the newer HUB versions. The executable gets deleted, but the new one is not installed

    upload_2018-7-7_8-59-28.png

    upload_2018-7-7_9-0-31.png

    also the update tried to install it again in C\programdata, while last time I have installed in a not protected folder to make it work

    it may just be that the installer is not starting with privileged permissions
     
  7. sebas77

    sebas77

    Joined:
    Nov 4, 2011
    Posts:
    591
    Starting the application as administrator doesn't fix the problem.
     
  8. yamlCase

    yamlCase

    Joined:
    Apr 13, 2017
    Posts:
    33
    This has been an ongoing problem with me as well... I've seen this exact issue the last 3 times I've tried to do the update. I end up having to just download and reinstall manually