Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

How to remove services from my project

Discussion in 'Unity Collaborate' started by MrDude, Sep 22, 2018.

  1. MrDude

    MrDude

    Joined:
    Sep 21, 2006
    Posts:
    2,569
    I tried using collab in the project but after realising that Collab is completely unusable I tried turning collab off. I then went to my dashboard and archived the project since there doesn't seem to be a delete option (weird).

    Now my project is forever telling me "You are not a member of this project" and each timeI try to build it nags me with a popup first saying "Because you are not a member of this project you won't be able to connect to any of the services. Do you want to continue building"

    In my services tab it just tells me (in a red background) that it failed to connect and then in a gray box it tells me "Unable to link project to Unity Services" and tells me to Refresh access (which does nothing since the project is archived) or to create a new link.

    I have gone so far as to remove the default installed packages like IAP and Analytics but no mattter what I do Unity is forever nagging me nonstop about not being a member of the project that only I am using. I am not a member of the project that is not being shared via source control. I first have to confirm that I want to build my local project to my local device each time I build because it warns me that I am not a member of this project that has no services attached to it...

    How do I make this stop!? I tried deleting the Library folder and basically everything except the Assets and Packages folders and STILL this is forever nagging me every single time I hit build.

    HOW DO I MAKE IT STOP!?

    If this was the first project, that would be one thing... but every single project that I used Unity services with (Collab, multiplayer...) and then decided "To hell with all these internal bugs. I'm quitting the use of all services" I ended up with this never ending barrage of "You are not a member of this project that is not associated with any services" console warnings, GUI error messages and popup buttons.

    HOW DO I MAKE IT STOP!?!?!!?

    Thanks

    P.s. Unity version I encountered this in: Various from 2017.3.0f up to 2018.2.6f

    Edit: I just checked the project settings folder nd found I have a file called UnityConnectSettings.asset
    Inside here a bunch of stuff is set to auto initialize so I changed all those 1's to 0's and restarted my project. Still, being warned that this project could not connect to services. So I just deleted the file completely and restarted Unity. Now the file gets created again but in binary so I can't change anything any more. Frustrating as hell to have to deal with Unity nonsense rather than doing the job I am being paid for! :(
     
    Last edited: Sep 22, 2018
  2. MrDude

    MrDude

    Joined:
    Sep 21, 2006
    Posts:
    2,569
    It seems not another soul on this planet knows this either so allow em to share what I eventually found and hopefully save others this pain in the ass and hopefully give Unity a heads up on this issue also...

    In another thread I read that you should modify the playersettings asset and make sure a that all services are set to 0, thus confirming they are disabled. That's all good and well except they all WERE 0 to begin with since I disabled all of them via the services panel already.

    Turns out that just below all those cloud services settings there was also a network project ID setting. Once I deleted this this frustration ended. Now, is there an option anywhere inside Unity where you can say "Stop linking this project to an online project"? Not that I can see. This means it'sup to you to manually edit the project settings file and hack this annoyance out of your project.

    The bad news is that the projectsettings.asset file is massive! The good news is that if you do a search for "cloud", everythign is then neatly placed together. The ID is 2 or 3 lines underneath the services.

    Hope this helps someone
     
    nopcode likes this.
  3. Kyuugatsu

    Kyuugatsu

    Unity Technologies

    Joined:
    Jan 11, 2014
    Posts:
    32
    Hi MrDude,

    You can unlink your project from services using the services window, it's under the 'Settings' tab.



     
  4. MrDude

    MrDude

    Joined:
    Sep 21, 2006
    Posts:
    2,569
    Thx. I'll thy that with a next project but I'm sure I did that ages ago...
    When I go to my services tab there was nothing there except an error message and 2 buttons:
    The first said "Refresh" and did absolutely nothing. The second said "Create a new link".
    That was it. The screen you posted, I didn't have that...

    Maybe in this instance I archived it first and that messed with Unity's head a bit. Next time I'll be sure to look for that option first and see if that saves me the headaches. Much appreciated :)
     
  5. RSH1

    RSH1

    Joined:
    Jul 9, 2012
    Posts:
    186
    Unlink project isn't working for me (2019.1.2f1)

    Pressing the 'unlink project' button on the Services tab does nothing.
     
  6. ryanc-unity

    ryanc-unity

    Unity Technologies

    Joined:
    Mar 23, 2016
    Posts:
    1,724
    Hi @RSH1, have you tried restarting Unity and then unlinking?
     
  7. Magasenakwa

    Magasenakwa

    Joined:
    Oct 13, 2018
    Posts:
    72
    Edit ProjectSettings/ProjectSettings.asset with a text editor.
    Search for "cloudServicesEnabled" and set everything to 0. Delete the project id if it's there.

    Just had to do that myself a few seconds ago :)
    Under the Services tab it lists there is no id and no services are setup but when I edit the asset file I saw that Unet was enabled. I think maybe that ws set from the PackageManager? Anyway, quick and simple fix :)
     
unityunity