Search Unity

how to optimize the setting in VR mode(Empty scene is still slow in HDRP)

Discussion in 'High Definition Render Pipeline' started by wenzy, Mar 14, 2020.

  1. wenzy

    wenzy

    Joined:
    Nov 17, 2015
    Posts:
    34
    hello community. I have followed this article and start to make some VR scene in HDRP.

    https://blogs.unity3d.com/2020/03/1...ces-with-the-high-definition-render-pipeline/

    I think I have already disable the unnecessary feature in the "HDRP asset settings".
    The setting file.
    (https://drive.google.com/file/d/1_-Zjr9PZ9MPazHxY4dEmEJrOhUaNeWa1/view)

    But the speed is still very slow. The same scene I have tested in URP can reach to 120 fps. But in HDRP, it's just 30 to 50 fps. I have tired to remove the scene object and seems helpless.From the state window I can see the Cpu usage is very high.

    Unity version 2019.3.2 . HDRP version 7.21

    Does anybody have some suggestions?

    ---------
    Some update:
    I found I double copy the XR Rig gameobject by accident. That's the main reason why the fps is abnormal.

    Still welcome any tips about VR optimization~ thanks
     
    Last edited: Mar 16, 2020
  2. rz_0lento

    rz_0lento

    Joined:
    Oct 8, 2013
    Posts:
    2,022
    Can you tell about your setup? Are you running HDRP in DX11 or DX12? Which GPU?

    DX12 is super slow atm.
     
  3. wenzy

    wenzy

    Joined:
    Nov 17, 2015
    Posts:
    34
    It's DX11.Mine is a laptop. CPU:i7-8750H GPU:RTX2080maxq
     
  4. foonix

    foonix

    Joined:
    Dec 15, 2019
    Posts:
    17
    I found that disabling unnecessary frame settings can save a lot of CPU side overhead. Go to Project Settings -> HDRP Default Settings, or disable on camera using custom frame settings overrides.

    HDRP seems to add a lot of "trivial case" overhead. An empty scene I would expect to see lower frame rate than legacy RP. But,it should scale well with scene complexity.

    If comparing performance, it's also worth comparing build vs build. I get much higher framerates in build than in editor. 30-50 fps in the editor is not unusual for me in fairly complicated scenes but then I get a solid 90 in build. In the editor, use the performance profiler and _just_ look at the camera render time to see if settings change makes a difference.
     
  5. wenzy

    wenzy

    Joined:
    Nov 17, 2015
    Posts:
    34
    Wow ,thank u. That's a very important tip to me. I found the reason why the scene is so slow. Have updated on the top~
     
unityunity