Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

How to get the same FOV in 3DSMax and Unity

Discussion in 'Editor & General Support' started by RoXCoder, Mar 21, 2012.

  1. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    Hi,

    I have tried everything and still cannot get this so simple stuff to work correctly.
    My FOV in Unity is 60 vertical and so does my "Camera01" in 3DSMax.
    But when i export the mesh with Camera01 and import it in Unity and then positioning + rotating my camera appropriately to Camera01, i don't get the same image.

    Why?
    And how can i fix that in MAX while keeping the FOV to 60 in Unity?
    I want to know so i will know how to tell my artist to configure his camera so it will match my config in Unity.

    Thanks.
     
    Last edited: Mar 21, 2012
  2. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    Anybody?
     
  3. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    9,436
    Are you using the same aspect ratio?

    (also I'm not sure if the FOV is for the vertical axis in max, maybe there is some mismatch there).
     
  4. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    There is no way to change the Aspect ratio in MAX.
    And in Unity i use Free Aspect, but changing between aspects gives me the SAME EXACT IMAGE except it widen, the mesh is still at the same exact position on the screen.
    And i already changed in MAX to use Vertical to match Unity and still the same thing.
     
  5. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    This issue is really frustrating to the point im going to give up on Unity.
     
  6. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    Bump.
    Its a basic asset import and yet nobody know?
     
  7. lucidcoder

    lucidcoder

    Joined:
    Mar 23, 2010
    Posts:
    138
    Aspect ratio has a lot to do with it, so if Max is rendering a 4:3 and your game is a 16:10 standalone, you won't get the same image.

    If that's not your problem, I'm not sure what to tell you. Can you post a comparison image of what you're talking about so that we could help you a bit more?
     
  8. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    I went literally through all google and there is nothing about aspect ratio in 3dsmax... very weird.
    And again, im using "Free Aspect" in Unity, and even if i change the aspect ratio in Unity, i get the same image except it widen, the mesh doesn't move or change in anyway.

    Image from Unity:


    Image from 3DSMax:


    You can see that in 3DSMax i use VERTICAL FOV not Horizontal like it's been said multiple of times.

    Any help would be greatly appreciated.
     
  9. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    I guess nobody know.
     
  10. BBG

    BBG

    Joined:
    Feb 27, 2012
    Posts:
    251
    Are you just changing the aspect ratio in Unity or are you actually changing the field of view setting in the inspector for the camera. Default is 60.

    Edit - Sorry misread your first post I see what you are asking. Is your camera in Unity the exact same distance from your model as it is in MAX. Sorry I don't use 3dsmax.
     
    Last edited: Mar 22, 2012
  11. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    Yes it is in the exact same distance since i use the Camera01 position exported with FBX, therefor it in the exact same position.
    And max is already configured as 1unit = 1 meter, so its not this issue.
     
  12. Andrew_atl

    Andrew_atl

    Joined:
    Sep 21, 2010
    Posts:
    103
    I don't use Max so I don't know all that setup, but if you are using 16:9 aspect ratio for Unity and you want 60 degrees horizontal, use 36 as the FOV.
     
  13. RoXCoder

    RoXCoder

    Joined:
    Mar 3, 2012
    Posts:
    98
    As i mentioned in my first post, i dont want to touch Unity FOV.
     
  14. Andrew_atl

    Andrew_atl

    Joined:
    Sep 21, 2010
    Posts:
    103
    Well this is the Unity forums, I would suggest going to the 3DS Max forums for help with 3DS Max.
     
  15. mattebo

    mattebo

    Joined:
    Apr 4, 2012
    Posts:
    1
    I see this is a week old so you probably figured it out by now but I thought I'd share some info. (I found this thread through a google search so forgive me bringing it back up.)

    Aspect Ratio is not explictly called Aspect Ratio in Max. Its just your render resolution.
    To change your Aspect Ratio in Max you need to change the Render Settings. Go to Rendering -> Render Setup in the menu bar. Under the Common tab you'll see the area called Output Size. You can either add your aspect in manually under custom or use a predefined one from the drop down. For instance due what I'm going for I set mine to HDTV and 1280x720 (which is an Aspect of 16:9.)
     
  16. networm045

    networm045

    Joined:
    Jun 8, 2012
    Posts:
    1
    First you must set the right aspect or output size in 3dsMax as the above. Second you should set a vertical FOV as same in Unity for 3dsMax. Because field of view is vertical in Unity.
     
  17. TwiiK

    TwiiK

    Joined:
    Oct 23, 2007
    Posts:
    1,710
    Just started animating a first person weapon myself and it's not that hard to set up.

    1. First set it up how you want it in Unity. Take a note of your resolution and camera fov.
    2. Find a fov calculator to convert Unity's vertical fov into horizontal fov so you can plug that into max. I just used this one (http://www.rjdown.co.uk/projects/bfbc2/fovcalculator.php)
    3. Put your camera at 0,0,0 in max and make sure that is your pivot for the exported model
    4. Open the render settings and set the same resolution in Max or at least the same aspect ratio
    5. Add your converted horizontal fov to the camera in Max (e.g 65 fov in Unity is 90 fov in max)
    6. Export the model and put it as a child of your camera in Unity making sure to zero out the local position values.

    Now you'll have the exact same image in 3ds max as in Unity.
     
  18. Tripple-Z

    Tripple-Z

    Joined:
    Mar 10, 2013
    Posts:
    1
    (This was answered above, sorry) There is indeed, a way to change aspect ratio in Max. Use render settings to set the view in the current frame. When a camera is added to the 3DS Max scene, it will frame in view with a yellow frame in the correct aspect ratio. When you align your animations, they will (almost) match your viewport if it is set in the same ratio.
     
  19. SDJrekoff

    SDJrekoff

    Joined:
    Sep 28, 2014
    Posts:
    1
    In render setup under image aspect put 1.6 (16:10), pixel aspect should be 1, lock n load.
     
  20. franman007

    franman007

    Joined:
    Apr 29, 2017
    Posts:
    14
    I'm having similar problems as RoxCoder and am reading off from TwiiK's post; based on my interpretation from his/her post I'm not getting the results I've expected.
    • I'll start off with the unit setup in 3Ds Max when matching with Unity's.
    upload_2017-10-28_10-22-58.png
    • Followed by my camera settings in Unity.
    upload_2017-10-28_10-30-27.png

    upload_2017-10-28_10-25-51.png
    • And finally, my camera settings in 3Ds Max.
    upload_2017-10-28_10-29-13.png

    What am I doing wrong and what am I missing? Also what type of camera should I use in 3Ds Max?

    BTW I'm using Unity3D 2017.2 and 3Ds Max 2018.
     
    Last edited: Oct 28, 2017
  21. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    9,436
    I don't use max, but judging from that settings screenshot, you need to switch the fov in the parameters to use vertical FOV (I'm guessing the arrows left of the FOV is a drop down, and you can switch that to Vertical), then use the same FOV degrees in both max and Unity.
     
  22. sivaprasadgonti

    sivaprasadgonti

    Joined:
    Jan 15, 2018
    Posts:
    1
    Hello @RoX coder: check the below link , basically the main difference is from both tools FOV setting up horizontal and vertical .



    hopefully this information will halp you.

    Best,
    SivaG
     
  23. mdentonetc

    mdentonetc

    Joined:
    Jul 23, 2012
    Posts:
    19
    Thank you! I was having this issue, and my problem was that Max uses horizontal based FOV by default while Unity uses Vertical. My scenes are now matching.
     
  24. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    29,159
unityunity