Search Unity

  1. Calling all beginners! Join the FPS Beginners Mods Challenge until December 13.
    Dismiss Notice
  2. It's Cyber Week at the Asset Store!
    Dismiss Notice

How to disable texture compression/filtering in WebGL?

Discussion in 'WebGL' started by RobbyZ, Apr 17, 2015.

  1. RobbyZ

    RobbyZ

    Joined:
    Apr 17, 2015
    Posts:
    18
    Hello,

    I would like to export my game to WebGL. It seems like the textures are either being massively compressed and/or filtered -- either of which are undesired for a pixel art game. Below is an image comparing webgl versus stand alone player.

    Note that small sprites show the effect heavily -- the sword cursor (image), the floor background (sprite), and the machine (sprite) are altered.

    Would be very appreciative if anyone has ideas :)

     
  2. jonas-echterhoff

    jonas-echterhoff

    Unity Technologies

    Joined:
    Aug 18, 2005
    Posts:
    1,633
    This looks like you are using a different texture resolution in WebGL then in Standalone. Is it possible that you have a different Quality setting selected on WebGL, and that that Quality setting is using a different Texture Quality setting?
     
  3. RobbyZ

    RobbyZ

    Joined:
    Apr 17, 2015
    Posts:
    18
    Ah, yep! That was it. I hadn't realized the default setting is half-res textures. Quick change there and it looks good now.

    Thanks much for your quick response!
     
  4. Keseren

    Keseren

    Joined:
    May 8, 2015
    Posts:
    3
    I have the same problem, how did you fix it? I'm pretty new here.
     
  5. valyard

    valyard

    Unity Technologies

    Joined:
    Jun 4, 2010
    Posts:
    290
    You go to Project Settings -> Quality Settings and make sure that for WebGL default quality you are using Texture Quality is set to Full Res.
     

    Attached Files:

    Peter77, Aurigan and Keseren like this.