Search Unity

How to disable fadings/blending in transitions?

Discussion in 'Animation' started by honigkuchen, Nov 26, 2013.

  1. honigkuchen

    honigkuchen

    Joined:
    Nov 24, 2013
    Posts:
    7
    Hi!
    I'm new to Mecanim and want to use it for simple 2D Animations.
    Currently i'm trying to create a door. It's closed at th beginning, when the Open-Parameter is set, the SlideOpen Animation should be played and then the door should stay in the DoorOpen State/Animation until the Open-Parameter is unset again.
    Everthing works fine, but i have no clue how to get rid of the fading in the transition (look @ screenshot). The animations itself are fine, but with the controller/transitions blending/fading stuff everything looks a bit jerky. Is there any way to simply disable the animation fading?

    Cheers! :)
     

    Attached Files:

  2. abeaulne

    abeaulne

    Joined:
    Oct 2, 2013
    Posts:
    2
    If you want to remove the blending, grab the blue arrow at the right side of the blend "window" and drag it over to the left, past the start of the blend window. Release it and it'll snap with the start of the blend window, removing the blend altogether.
     
    SantaG, arinu3d and _ME4T like this.
unityunity