Search Unity

  1. Megacity Metro Demo now available. Download now.
    Dismiss Notice

Bug How to debug WebGL after build

Discussion in 'Web' started by Landa-100, Nov 17, 2023.

  1. Landa-100

    Landa-100

    Joined:
    Sep 9, 2018
    Posts:
    72
    My project is always working well after building to Win11 Desktop and in Unity real-time renderer window after "play"!
    upload_2023-11-18_1-52-31.png
    I got this error after my mouse was over the "Helm" or "Life Potion", The UI was built on the UI toolkit.
    Can someone give some tips on how to position the bug came from?

    Unity Version 2023.3.0a14<DX11>

    upload_2023-11-18_2-2-40.png
     
  2. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    5,797
    Make a development build, and under Player Settings, enable exception handling with full stacktrace.
     
  3. Landa-100

    Landa-100

    Joined:
    Sep 9, 2018
    Posts:
    72
    It seems the full stacktrace has been opened, white color logs printed below link to a well functionality
    upload_2023-11-18_3-37-30.png

    these red logs were thrown which means the real bug is.I have no clue where to trace the error from, because there is no function name related to my C# code, especially in this error list.
    upload_2023-11-18_3-32-16.png
     

    Attached Files:

    Last edited: Nov 17, 2023
  4. jukka_j

    jukka_j

    Unity Technologies

    Joined:
    May 4, 2018
    Posts:
    953
    This call stack does suggest like a possible bug in Unity's InputSystem package. Reading the call stack, I don't know what could cause a user programming error to raise an exception inside the InputSystem InputModule code like that - and even if there is one, it would be nice to get the InputSystem package to give a more meaningful and diagnosable error.

    I would recommend raising this as a bug report. That way the error message could be improved at least, even if it was something in the user code.
     
  5. Landa-100

    Landa-100

    Joined:
    Sep 9, 2018
    Posts:
    72
    I have back to the stable version 2022.3 and rebuilt again no code was changed!
    upload_2023-11-21_0-53-35.png
     

    Attached Files:

  6. unityruba

    unityruba

    Unity Technologies

    Joined:
    Nov 6, 2020
    Posts:
    270
    definitely not a bug we want to see in the newer versions, because it marks a regression!

    @Landa-100 can you open a bug report please so we can take a look? it'd speed this up a lot. (also, great profile pic!)
     
  7. Landa-100

    Landa-100

    Joined:
    Sep 9, 2018
    Posts:
    72
    Sure, the reason why I backed to Stable Version Editor 2022.3 is the latest version is not able to build
    either Windows Platform or WebGL, so I deleted that. In addition, Build project also includes fatal bugs.

    How to open a bug report to improve Unity?
     
  8. KamilCSPS

    KamilCSPS

    Joined:
    May 21, 2020
    Posts:
    448
  9. Landa-100

    Landa-100

    Joined:
    Sep 9, 2018
    Posts:
    72
  10. Landa-100

    Landa-100

    Joined:
    Sep 9, 2018
    Posts:
    72
    Hi! unityruba Has your team found the main issue of this bug?:eek:
     
  11. KamilCSPS

    KamilCSPS

    Joined:
    May 21, 2020
    Posts:
    448
    Bugs don't go directly to a specific Unity dev from this forum... might want to share the bug case # with the dev.
     
    Landa-100 likes this.
  12. cpaganucci

    cpaganucci

    Joined:
    Mar 4, 2014
    Posts:
    2
    @Landa-100 Do you have the bug case number so we can follow progress on this bug? Thanks!
     
  13. unityruba

    unityruba

    Unity Technologies

    Joined:
    Nov 6, 2020
    Posts:
    270
    t_paine likes this.