Search Unity

How to build mono(libmonobdwgc-2.0.so) for linux

Discussion in 'Linux' started by GollumZzz, Nov 4, 2019.

  1. GollumZzz

    GollumZzz

    Joined:
    Aug 1, 2012
    Posts:
    24
    I am using Unity 2019.1.14 and want to do some experment with mono builtin by Unity in Ubuntu.
    I want to find a way to update the mono library in my Linux build, is that libmonobdwgc-2.0.so?
    first I checkout the code in https://github.com/Unity-Technologies/mono.git
    my steps are below
    ./autogen.sh
    make
    for branch unity-2019.1, the errors are
    Makefile:911: recipe for target 'unity_utils.lo' failed
    make[3]: *** [unity_utils.lo] Error 1
    How to fix it?
     
unityunity