Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Question How do you enable GPU Instancing for imported models?

Discussion in 'General Graphics' started by Deleted User, Mar 28, 2022.

  1. Deleted User

    Deleted User

    Guest

    Is there a way to Enable GPU instancing from 3D models? I'm trying to use ECS. My batches are constantly over 20,000. The GPU Instancing option is grayed out on all my materials for this model. My framerate is suffering.


     

    Attached Files:

    Last edited by a moderator: Mar 28, 2022
  2. Deleted User

    Deleted User

    Guest

    Nevermind. I made a new material and enabled GPU instancing on it, then assigned all the materials from my model to this new one. The batches went from +20000 like in the screenshot to about 56, which is what I wanted. This, however, still didn't bring the fps up. It's only about 1000 entities, which tbh I didn't think was alot. for example, my pc can run the boid sample project from unity's github with well over 25,000 entities. These ran in a newer version of ecs than I'm using though, so maybe my version is just bad/old.