Search Unity

How do I prevent objects from falling through a plane?

Discussion in 'Physics' started by llewellynathan, Nov 27, 2019.

  1. llewellynathan

    llewellynathan

    Joined:
    Sep 6, 2019
    Posts:
    10
    I have downloaded a model from Mixamo to use in a game for school. I'm using a plane to represent the ground. The Mixamo model has a character controller component on it, a mesh collider (no trigger), and a rigidbody (gravity on). The plane has a rigidbody (gravity off) and a mesh collider (no trigger). There is also a cube object in the scene with a rigidbody (gravity on) and a box collider (no trigger). When I press play the model and the cube both fall through the plane. How do I make it so they stop on top of the plane rather than fall through? See the pictures for my setup of each object.
     

    Attached Files:

  2. devotid

    devotid

    Joined:
    Nov 14, 2011
    Posts:
    373
    Make sure to set the Mesh object on the MeshCollider Component. Without it it wont work.
    also make sure to set the Physics materials in the colliders components.
    Last make sure that the layers are able to interact. Check in the physics area under game settings.