Search Unity

How do I add the "Oculus (Standalone)" package?

Discussion in 'VR' started by aaronfranke, Jun 13, 2019.

  1. aaronfranke

    aaronfranke

    Joined:
    Jan 23, 2017
    Posts:
    18
    I'm getting this message when trying to set up Unity for VR dev with my Oculus Go:

    Code (csharp):
    1. Package missing for Virtual Reality SDK Oculus. Please add the Oculus (Standalone) package using the Package Manager Window.
    2. Will attempt to enable None instead.
    3.  
    However, in the package manager window, I only see two items for Oculus: "Oculus (Android)" and "Oculus (Desktop)". I do not see "Oculus (Standalone)" anywhere. I already have "Oculus (Android)" installed and it still gives me this message.
     
  2. luigix

    luigix

    Joined:
    Mar 13, 2010
    Posts:
    15
    Exactly the same here.
    It's driving me crazy (on MacOS Mojave for the records still haven't tried on windows)
     
  3. darkesco

    darkesco

    Joined:
    Mar 19, 2015
    Posts:
    27
    I think it means Oculus Desktop. Even if you are developing for another platform, it may need this for oculus framework stuff. For me, I couldn't test my GearVR app in the Rift without it.
     
  4. aaronfranke

    aaronfranke

    Joined:
    Jan 23, 2017
    Posts:
    18
    Even if that's all it actually needs, it still shows a warning.
     
  5. StayTalm_Unity

    StayTalm_Unity

    Unity Technologies

    Joined:
    May 3, 2017
    Posts:
    77
    Hello,
    I'm not 100% sure, but I believe this is something a colleague has a fix for coming down the pipe.

    In some cases our package manager and XR Settings get a little confused. If your issue is the same one then try going to Project Settings -> Player -> XR -> XR Enabled
    And basically toggle that enabled flag. It's a known bug in some cases when updating, and I hope it unblocks you.

    Let me know if that helps :)
     
    aaronfranke likes this.