Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

How can I build for Blackberry now with 5.3.2p2?

Discussion in 'BlackBerry' started by giorgos_gs, Feb 4, 2016.

  1. giorgos_gs

    giorgos_gs

    Joined:
    Apr 23, 2014
    Posts:
    559
    I am pro user. Using a Win10 PC.
    Can I also install an older version of Unity with BB10 support?
    How can I do this? I already have my second PC license on my mac.
    I cannot delete the 5.3.2p2 version and install 5.1 each time I want to build my BB10 game?
    People are still interested in my BB10 games!!!!
     
  2. giorgos_gs

    giorgos_gs

    Joined:
    Apr 23, 2014
    Posts:
    559
    I think the best solution is let people add a patch to 5.3 Unity to add the blackberry 10 support as it is if they need to do this. This is not hard to implement at all. You guys dont have to update the platform anymore but its running fine as it is and its a shame to lose that platfoms since its already working fine! some of us make some money from this platform because now its not that crowded like Android and iOS.
     
  3. mr_zog

    mr_zog

    Joined:
    Jan 21, 2014
    Posts:
    165
    No chance, we have talked to support about this.
    4.6 is the last working BB10 version for us :/

    It would be cool if they would have open sourced it and let the community maintain it.
     
  4. giorgos_gs

    giorgos_gs

    Joined:
    Apr 23, 2014
    Posts:
    559
    This is a great idea, have they replied about it?
     
  5. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Guys its pointless, BlackBerry is going all Android...
    Sooner or later they will need to drop it and this is all part of the grand plan...
    Which makes sense to me.!
    I was against BB being dropped but moved on now..
     
  6. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    And thats not correct, you have 4.7 final and some 5.2 version also..
     
  7. Wajdik

    Wajdik

    Joined:
    Feb 4, 2015
    Posts:
    204
    Which 5.2 version is working for BlackBerry 10?
     
  8. AlexThibodeau

    AlexThibodeau

    Unity Technologies

    Joined:
    Jul 23, 2013
    Posts:
    309
    The BlackBerry module was removed in 5.3.0. So any 5.2 version should work. I would recommend using the last of the 5.2 releases since it will have the most fixes.
     
  9. Wajdik

    Wajdik

    Joined:
    Feb 4, 2015
    Posts:
    204
    Installed Unity 5.2.3p3 and I can't build for BlackBerry (in Build Settings I have "No BlackBerry module loaded.")
     
  10. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Why would you install a patch release, the latest is 5.2.4 version.
    http://forum.unity3d.com/threads/discontinuation-of-unity-support-for-blackberry-10.332693/page-3
    If you read this thread you know more.. Anyway I think your posting is annoying because its clear in the thread and already discussed a number of times, so why confuse things.. Do not understand what the confusion is, if you followed properly and real BlackBerry developer you see when the last version was..
     
  11. Wajdik

    Wajdik

    Joined:
    Feb 4, 2015
    Posts:
    204
    To make it short, the latest version that can build for BlackBerry is 5.1.4, all the 5.2.x versions can't build for BlackBerry, that's correct?
     
    Last edited: Feb 16, 2016