Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug How can I attenuate a ReverbZone through an AudioMixer?

Discussion in 'Audio & Video' started by flimflamm, Nov 25, 2021.

  1. flimflamm

    flimflamm

    Joined:
    Jan 6, 2020
    Posts:
    43
    I'm governing the attenuation of all my game SFX through audio-mixer groups (setting the mixer output of relevant audio-sources to the SFX group, and setting the volume of that group), but any ReverbZones I use seem to ignore that mixer's attenuation setting entirely. The result is that I can hear the echo of muted sound effects...

    Is there any way to correctly route a reverb zone through an audio-mixer?

    I assumed this would not be the case for ReverbZones, so I'm wondering if it's a bug that exists in my unity version (2022.1.0.a12), or if there is a setting somewhere for this...
     
  2. mi3ke

    mi3ke

    Joined:
    Mar 3, 2015
    Posts:
    8
    I have the exact same issue on 2022.2.0f1. In previous versions ReverbZones would respect the mixer-level. So this must be a bug. I hope it gets fixed soon.
     
  3. DandecatLiang

    DandecatLiang

    Joined:
    Aug 22, 2017
    Posts:
    26
    Same here, wait fixed.
     
  4. gnovos

    gnovos

    Joined:
    Apr 29, 2020
    Posts:
    26
    same