Search Unity

High CPU Usage!

Discussion in 'Linux Editor' started by Scellow, Aug 26, 2015.

  1. Scellow

    Scellow

    Joined:
    Jan 25, 2013
    Posts:
    32
    Hello

    I did a fresh Ubuntu install (Ubuntu 15.10, i'm using kernel 4.2 RC8 with open source driver for my HD 7770)

    Screen:
    http://i.imgur.com/ZyHLTBP.png

    And XOrg log in attachment
     

    Attached Files:

  2. TheFrozenFires

    TheFrozenFires

    Joined:
    Jul 5, 2013
    Posts:
    8
    I'm also experiencing this on 15.04 Ubuntu Gnome. Doesn't seem to be laggy though
     
  3. thegigaraptor

    thegigaraptor

    Joined:
    Aug 26, 2015
    Posts:
    11
    I'm also seeing high CPU usage on open: Ubuntu 14.04
    Screenshot from 2015-08-26 18:45:15.png Screenshot from 2015-08-26 18:45:31.png
     
  4. Chaoseiro

    Chaoseiro

    Joined:
    Aug 28, 2013
    Posts:
    40
    I'm also experiencing Unity taking a whole core for itself
     

    Attached Files:

  5. grandmastermoth

    grandmastermoth

    Joined:
    Aug 27, 2015
    Posts:
    2
    Also experiencing high CPU usage in an empty project. Intel i5 with HD4000 and Ubuntu Gnome 15.04
     
  6. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    184
    I'm also getting this on arch linux. The windows version running on wine takes about 40~50% so it looks like there's something going on.
     
  7. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    965
    This is a known issue - idle cpu usage is (much) higher than it needs to be.
     
  8. zapu

    zapu

    Joined:
    Aug 27, 2015
    Posts:
    5
    Same problem in login screen (I'm on xubuntu 14.04) - top reports 100% CPU usage.
     
  9. bedorlan

    bedorlan

    Joined:
    Aug 16, 2015
    Posts:
    12
    in debian 8
     

    Attached Files:

  10. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    25,935
  11. Tomnnn

    Tomnnn

    Joined:
    May 23, 2013
    Posts:
    4,137
    Still less CPU usage than chrome's pepper flash.

    Mmm.. maybe I'll wait to give the linux editor a shot.
     
    Ryiah likes this.
  12. DoctorJellyface

    DoctorJellyface

    Joined:
    Nov 6, 2012
    Posts:
    73
    OK, since everyone's chiming in, I also experience this bug, Arch Linux.
     
  13. Ryiah

    Ryiah

    Joined:
    Oct 11, 2012
    Posts:
    14,905
    hippocoder likes this.
  14. dzupin

    dzupin

    Joined:
    Apr 20, 2015
    Posts:
    5
    I also have 100% of utilization of whole core when Unity is doing nothing.
    I even read known issue report and failed to realize that "Idle CPU usage is higher than it should be" means 100% for whole core.
     
  15. Tomnnn

    Tomnnn

    Joined:
    May 23, 2013
    Posts:
    4,137
    Hopefully people aren't using apple machines to test the linux editor. For whatever reason, apple decided to go back to dual core... and make models with GPUs more expensive. My 2012 mac is more powerful than the 2015 mac (of the same price). Anyone using a 'modern' Apple computer that they didn't spend at least 3k on will get 50% hardware utilization from this bug if they are running linux :D
     
  16. Ryiah

    Ryiah

    Joined:
    Oct 11, 2012
    Posts:
    14,905
    Which specific line are you referring to? The iMacs have quads as well as duals.
     
  17. Tomnnn

    Tomnnn

    Joined:
    May 23, 2013
    Posts:
    4,137
    The minis :p I was looking into desktops for future purchases, but no way will that be from apple. The computers at work couldn't even run the unreal editor lol. It just wouldn't be worth the money I'd need to put in to get a GPU and a decent amount of RAM. I might as well wait for the nvidia pascal :)

    I'm putting a new computer off for a while. I'm accepting the reality of population count on dedicated machines. I enjoy CoD because it's fast paced and there's always people playing. On dedicated systems, that is. On PC, the community starts between 50k and 100k, then over a few months drops down to 1k to 4k. It's crazy. On ps3 the call of duty game from 3 years ago has 130,000 people still! I prefer PC for most things, but I am settling for console gaming for multiplayer games. I bought a 3ds solely to play monster hunter and now I'm buying a PS4 solely to play cal of duty. If I wanted the highest player count I suppose xbox one would be the better option, but as long as the games have over 100,000 people there's no trouble in finding games.
     
  18. bedorlan

    bedorlan

    Joined:
    Aug 16, 2015
    Posts:
    12
    The high cpu usage is related to the tab "game". when i reduce the size of this tab, the cpu drops to 30% ... sometimes ...
     
  19. peladovii

    peladovii

    Joined:
    Nov 1, 2010
    Posts:
    25
    I get 100% CPU core-cycling while on the startup splash screen


    Once inside the editor it settles at 40% on all cores
     
  20. mikkom

    mikkom

    Joined:
    Sep 2, 2015
    Posts:
    1
    I'm experiencing this same bug. It makes the editor unusable as cpu gets really hot and the fan is running on high speed all the time.

    Minimizing or closing game or scene view has no effect.

    Attached: Top screenshot with cores. (The computer is a laptop)
     

    Attached Files:

    Last edited: Sep 2, 2015
  21. Scramblejams

    Scramblejams

    Joined:
    Oct 19, 2015
    Posts:
    6
    Very grateful for the Linux port, all!

    I have the same issue, Debian Sid 64-bit on a Thinkpad T410, Nvidia driver 340.96, Unity Editor 5.3.1f1. Varies between a constant 50% and 100% usage of a single core, even when I have nothing in it running.
     
  22. Scellow

    Scellow

    Joined:
    Jan 25, 2013
    Posts:
    32
    6 month now and issue still exist.... c'mon

    Unity 5.3.3f1+20160223
     
  23. kmare

    kmare

    Joined:
    Jan 30, 2016
    Posts:
    34
    Same here on fedora 23, ivy bridge i5, 8GB of ram, gtx 650ti.
     
  24. u_rs

    u_rs

    Joined:
    Jan 5, 2016
    Posts:
    147
    One of cores works at 100%.
    Ubuntu 14.04.
    Intel(R) Celeron(R) 2957U @ 1.40GHz,
    Haswell-ULT Integrated Graphics Controller
     
  25. vis2k

    vis2k

    Joined:
    Sep 4, 2015
    Posts:
    3,303
    Could be worse, at least we can run it on Linux :)
     
    Satscape likes this.
  26. earthflyer

    earthflyer

    Joined:
    Mar 19, 2016
    Posts:
    1
    Same issue. Ubuntu 15.04 x64, Intel i5 Quad core, HP Spectre laptop, 8Gb RAM.

    100% regardless of splash screen, idle editor, new project prompt, etc.
     
  27. LukaKotar

    LukaKotar

    Joined:
    Sep 25, 2011
    Posts:
    378
    I'm only getting a steady 30% in 5.4, but if I open an asset store window it quickly bumps random cores to 100% until I close it again. I didn't try 5.3.4 yet, so I can't say if it's fixed there.

    Edit: Spoke too soon, CPU usage still occasionally jumps to (and stays at) 100% on one core.
     
    Last edited: Mar 21, 2016
  28. Lisovskaya

    Lisovskaya

    Joined:
    Mar 19, 2016
    Posts:
    7
    100% cpu, and Unity can't start. I see only 2 windows: one gray, and second dark green with unity logo.

    All versions after 5.2.2f1, including latest 5.4.0b10 are affected. 5.2.2f1 without this bug, but has some over interesting bugs :)

    Centos 7, Core2Quard, GeForce GTX 275

    I see, in release notes:

    Release Notes:
    • Really actually fix "gray welcome window" issue
    Probably it's my bug, and actually it's not fixed.

    From
    ~/.config/unity3d/Editor.log:


    Using monoOptions --debugger-agent=transport=dt_socket,embedding=1,defer=y,address=0.0.0.0:56252
    Desktop is 1920 x 1080 @ 60 Hz

    Selecting FBConfig
    GLX_FBCONFIG_ID=237
    GLX_BUFFER_SIZE=24
    GLX_DOUBLEBUFFER=1
    GLX_RED_SIZE=8
    GLX_GREEN_SIZE=8
    GLX_BLUE_SIZE=8
    GLX_ALPHA_SIZE=0
    GLX_DEPTH_SIZE=24
    GLX_STENCIL_SIZE=8
    GLX_SAMPLES_ARB=0
    GLX_SAMPLE_BUFFERS_ARB=0
    GLX_STEREO=0
    GLX_CONFIG_CAVEAT=NONE

    Error: execv(npm): No such file or directory

    (Filename: /home/builduser/buildslave/unity/build/Editor/Platform/Linux/EditorUtility.cpp Line: 36)

    ListPackages failed, output:
    Error: execv(npm): No such file or directory

    (Filename: /home/builduser/buildslave/unity/build/Editor/Platform/Linux/EditorUtility.cpp Line: 36)

    InstallEditorPackages failed, output: process_set_termination_details: error looking up process handle 0x401

    installJavascriptPackages failed

    (Filename: /home/builduser/buildslave/unity/build/Runtime/Utilities/Argv.cpp Line: 168)


    LICENSE SYSTEM [2016320 8:30:12] No start/stop license dates set

    LICENSE SYSTEM [2016320 8:30:12] Next license update check is after 2016-03-20T22:23:14

    [0320/083012:ERROR:gpu_process_transport_factory.cc(402)] Failed to establish GPU channel.
    Error loading file:///%2Fhome%2Fshaggycat%2F.local%2Fshare%2Funity3d%2FPackages%2Fnode_modules%2Funity-editor-home%2Fdist/index.html#/project/recent


    (Filename: /home/builduser/buildslave/unity/build/Editor/Platform/Interface/NativeWebViewWindow.cpp Line: 50)

     
  29. Lisovskaya

    Lisovskaya

    Joined:
    Mar 19, 2016
    Posts:
    7
  30. Eknoes

    Eknoes

    Joined:
    Sep 15, 2015
    Posts:
    56
    Same problem. 1 core is constantly at 100% usage in 5.3.4
     
  31. Meowcate

    Meowcate

    Joined:
    Mar 19, 2016
    Posts:
    2
    Hello here. Got the same problem on Mint 17 with Unity 5.3.

    Possible workaround : always stay in Game Mode (in fact, nope. See my edit)

    So the problem is about "idle". That's strange, but if you don't want your Unity using 100% of the core, you can just enter Game mode. Unity will be reasonable and drop to ~20-40% CPU (for me).
    But you can't exit Game mode : stopping or pausing it will increase the CPU usage again.

    I'm not sure this is a good thing, but for the moment it's much more efficient to have a demo running than nothing at all. If you don't need the game screen, you should just make it as small as possible before running it.
    --
    EDIT : I don't know Unity, I'm still looking tutorials, and I didn't see what you do while in Game mode is removed when exiting Game mode. Not such a good workaround in the end.
     
    Last edited: Mar 21, 2016
  32. kmare

    kmare

    Joined:
    Jan 30, 2016
    Posts:
    34
  33. u_rs

    u_rs

    Joined:
    Jan 5, 2016
    Posts:
    147
    Would be nice to know about probability that this bug will be fixed in this year. Is it in some queue, if so then it should be bug #1 - that is most cruel problem that makes almost impossible to use it on Linux, and the other bugs should be deferred for later.
     
    saeidzeb likes this.
  34. arcooke

    arcooke

    Joined:
    Sep 1, 2014
    Posts:
    29
    Any updates to this issue? This is absolutely driving me insane. It spins up my CPU fan really loud while I'm working.
     
  35. Odd-Redesign

    Odd-Redesign

    Joined:
    Jul 26, 2013
    Posts:
    134
    Unity3D is using one of my cores 100% in idle. I attached a screenshot showing that.

    Personally, I don't feel like this is making a big difference in general performance. I'm running a very big and quiet CPU cooler though, so I don't notice a sudden spike in spin speed.
     

    Attached Files:

  36. vis2k

    vis2k

    Joined:
    Sep 4, 2015
    Posts:
    3,303
    This did turn out to be quite annoying on a Laptop, can confirm.
     
  37. maquis

    maquis

    Joined:
    Feb 7, 2016
    Posts:
    61
    same behavior here...
     
  38. BestCommie

    BestCommie

    Joined:
    Sep 28, 2015
    Posts:
    8
    If they wouldn't would they search for "unity high cpu usage" ??

    Can someone confirm if it is resolved at 5.4.0b13?
     
  39. kmare

    kmare

    Joined:
    Jan 30, 2016
    Posts:
    34
    it's not fixed with 5.4.0b13
     
  40. LukaKotar

    LukaKotar

    Joined:
    Sep 25, 2011
    Posts:
    378
    5.4.0b13 seems to slightly improve things for me. The CPU usage is high, but it never seems to hit 100% on any core unless I have the game view tab open. This is how it looks in the scene view, with lighting disabled:


    Oddly, turning the lighting on in the scene view brings the CPU usage down even more, maxing out at about 50% in my case. Notice how the CPU usage suddenly drops when I enable the lighting:
     
    vis2k likes this.
  41. LevyNagy

    LevyNagy

    Joined:
    Jul 21, 2015
    Posts:
    7
    Same thing here, and CPU usage dramatically drops for me when I play a game in the editor to 10-15%
     
    Last edited: Apr 12, 2016
  42. DrakkenWulf

    DrakkenWulf

    Joined:
    Mar 6, 2015
    Posts:
    10
    Yet another in the High CPU category on a laptop. Makes it unusable because my lap can't take the heat.
    Ubuntu 15.10 on Intel® Core™ i7-5500U CPU @ 2.40GHz × 4
     
  43. aaulia

    aaulia

    Joined:
    May 5, 2014
    Posts:
    4
    Arch Linux 5.4f1 from AUR, can confirm, 100% CPU usage only on one core at all times (idle or not). Uninstalling for now, since I'm on a laptop.
     
    kmare likes this.
  44. yifeng8

    yifeng8

    Joined:
    Jan 12, 2016
    Posts:
    1
    Hi all, i figured out a workaround by using cpulimit

    before
    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    5772 yifengs+ 20 0 2166256 321184 156624 R 103.8 2.0 0:12.05 Unity

    Unity is using 100% of one CPU core, then limit its CPU usage to 20%
    # cpulimit -p 5772 -l 20

    after

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    5772 yifengs+ 20 0 2176208 333740 156700 R 19.4 2.0 0:29.92 Unity

    The usage is limited around 20%. Though Unity runs a little slower, but my laptop won't burn my hands any more :D
     

    Attached Files:

    Odd-Redesign likes this.
  45. DrakkenWulf

    DrakkenWulf

    Joined:
    Mar 6, 2015
    Posts:
    10
    Here's a perf file I recorded. Obviously I don't have symbols, but as I understand it you can resymbolicate if you have them. This is Unity 5.3.4f1 on Ubuntu 15.10, 64 bit i7. Recorded with
    perf record -g -- /opt/Unity/Editor/Unity
     

    Attached Files:

    • perf.zip
      File size:
      836.7 KB
      Views:
      272
  46. aaulia

    aaulia

    Joined:
    May 5, 2014
    Posts:
    4
    Would using 'nice' be better than cpulimit (hard limit) ? Can't tested it out sadly, installing Unity again would blow past my metered internet quota >.<
     
  47. paddywwoof

    paddywwoof

    Joined:
    Apr 19, 2016
    Posts:
    11
    nice doesn't work, still over 100% with nice set to +19 (presumably cpu would drop below 100% for unity if I started several other cpu intensive processes but that probably wouldn't help)

    If I run cpulimit at less than 50 unity definitely slows (especially when playing) but possibly to get a compromise that generates significantly less heat. Oddly; unregulated, it only seems to go up to around 100 when it's not doing anything, it drops down to around 50 when playing!
     
  48. BestCommie

    BestCommie

    Joined:
    Sep 28, 2015
    Posts:
    8
    Not exactly relevant but is there a way to enforce minimum cpu frequency on linux(mint) cause seting the governor to power save doesn't appear to work...
     
  49. BestCommie

    BestCommie

    Joined:
    Sep 28, 2015
    Posts:
    8
    Found the solution to setting max-min freq. You need cpufrequtils. This is one more workaround NOT a solution :(
    1 install cpufrequtils
    2 go Sudo
    3 cpufreq-set -u x (where x is in Mhz e.g 2400000 for 2.4Ghz)
    for more help type cpufreq-set -h
    Hope this helps. Yes it limits system processing power but you won't waste your battery as fast as possible.
     
  50. BestCommie

    BestCommie

    Joined:
    Sep 28, 2015
    Posts:
    8
    Can someone confirm if there is any change in v5.4.0b16 ? Also i currently am at 5.3.4 is it worth upgrading ?? Is the latest stable/better than before or worse?
     
    Last edited: May 5, 2016