Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Question Help with preloaded assets changing itself to 1

Discussion in 'Editor & General Support' started by SnowTauren, Jun 14, 2020.

  1. SnowTauren

    SnowTauren

    Joined:
    Feb 15, 2016
    Posts:
    13
    Whenever I click build & run. A change is detected by collaborate in ProjectSettings.asset. It sets my preloaded asset to 1 and the ID for that file is set to 0. Most of the time after saving the project it reverts the change but sometimes it does not. I have already tried deleting all scripts and assets in my project yet I still have the problem. I'm not using any preloaded assets.

    So I have to revert this file every time before publishing changes to the cloud. Otherwise, with time I get multiple preloadedAssets with 0 fileID.

    Here is the change difference:
    upload_2020-6-14_11-28-58.png
     
    Last edited: Jun 14, 2020