Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

HDRP with no fog results in a regular material that is blindingly bright

Discussion in 'High Definition Render Pipeline' started by ZeroSinner, Jan 26, 2020.

  1. ZeroSinner

    ZeroSinner

    Joined:
    Apr 12, 2013
    Posts:
    13
    Hey I tried disabling fog in an empty scene with a single cube in the center with a default new material, and as soon as the cube is visible on camera is becomes blindingly bright.

    upload_2020-1-26_17-41-39.png

    Am I doing something wrong?

    [EDIT]

    Forgot to mention I'm using 2019.3.0f5, with the latest HDRP 7.1.8
     
  2. fuzzy3d

    fuzzy3d

    Joined:
    Jun 17, 2009
    Posts:
    229
    Last edited: Jan 28, 2020
  3. ZeroSinner

    ZeroSinner

    Joined:
    Apr 12, 2013
    Posts:
    13
    Thanks for the reply @fuzzy3d.

    In general do you know if there is anyway to keep bloom in check without enabling fog? or is that simply a requirement for HDRP to give sensible results?

    To me it kinda feels like a bug?
     
  4. SebLagarde

    SebLagarde

    Unity Technologies

    Joined:
    Dec 30, 2015
    Posts:
    936
    Hi,
    We advice to always create a new scene either from the template or from the HDRP wizard so it is properly configure.
    We have default settings with default volume profile when you create a scene in this case:
    https://docs.unity3d.com/Packages/c...ition@7.1/manual/Default-Settings-Window.html
    you are free to provide your own default profile.
    Then you can use volumes in scene to override those default settings, you can disable/enable any effects at the granularity of volume component.
    https://docs.unity3d.com/Packages/com.unity.render-pipelines.high-definition@7.1/manual/Volumes.html
     
  5. ZeroSinner

    ZeroSinner

    Joined:
    Apr 12, 2013
    Posts:
    13
    Thank you @SebLagarde. I will experiment with that later today.