Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

HDRP: Very high GPU consumtion in idle editor

Discussion in 'High Definition Render Pipeline' started by Alan47, Dec 4, 2019.

  1. Alan47

    Alan47

    Joined:
    Mar 5, 2011
    Posts:
    163
    Hi,

    I've noticed that the Unity editor causes very high GPU usage (between 60% and 90%) in the following scenario:

    - HDRP render pipeline
    - Editor window open (game not running)
    - Editor completely idle (no 3d movement)
    - Visual effects stack active
    - No lightmapping or other background processes going on.

    This is odd, because nothing is happening in the scene, it's literally a static image.

    What's also interesting: if I turn off "Animated materials", the GPU usage drops to zero, even though I don't even have any animated materials in my scene...

    Anybody else bumped into this?
     
    imagining and Olmi like this.
  2. Olmi

    Olmi

    Joined:
    Nov 29, 2012
    Posts:
    1,553
    Hi,

    I've noticed similar behavior (Unity 2019.3, HDRP 7.1.6). If I have my prototype content here on screen (simplish grey-boxing stuff) often the GPU usage is around 60-75%. Editor view, camera and Inspector visible, nothing happening and I got automatic lightmap baking etc off.

    Now that you mentioned animated materials option, I tried it and GPU usage drops. Good find, as I don't want to wear out my hardware for no good reason.
     
  3. imagining

    imagining

    Joined:
    Dec 30, 2019
    Posts:
    1
    Thank you! I was running into the same problem, it was often at 100% GPU usage and it was driving me nuts. Turning off animated materials in the scene view is fixed it.

    Screen Shot 2019-12-30 at 1.55.25 PM.png