Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Feedback HDRP Particle System Shaders

Discussion in 'Particle System Previews' started by richardkettlewell, Mar 13, 2019.

  1. kilik128

    kilik128

    Joined:
    Jul 15, 2013
    Posts:
    874
    we can resume how got hdrp particle at this time ? please
     
  2. sebastianzander

    sebastianzander

    Joined:
    Mar 22, 2018
    Posts:
    22
    Hi, I am using Unity 2019.1.10f1 with HDRP 5.16.1. An hour ago I downloaded the Unity Particle Pack assets and tried to create a simple dust storm. I then downloaded ParticlesShaders-HDRP5.7.2-2019.zip and switched the particle material shaders to ParticleLit. For the "biggest" part of the particle textures this works, however I get unpleasant looking specular spots as a reflection from the sky light:

    hdrp_particle_shader_artifacts_1.jpg

    These spots are only visible when looking into the same direction as the directional sky light is radiating. Its a rather tight viewing angle/cone - outside of it they are not visible.
    Also there is this vertex stream/shader input mismatch for the TANGENT and TEXCOORD streams. I could find and add the TANGENT stream to the particle system, but there is no TEXCOORD stream to be found. I don't even know if this is connected to the specular spot artifacts since the UV mapping of the dust texture seems to be correct. Any idea?
     
    Last edited: Jul 26, 2019
  3. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    1,208
    This part is going to be a bit tricky. The old Standard Particle Shaders has a custom GUI and a button to automate setting the correct streams, but right now there is nothing for the Shader Graph shaders - instead it is down to you to know what you are using, and use the error messages to guide you.

    In general:
    * If the shader graph is using normal mapping, it will need the Tangent stream
    * If using the blended flipbooks, you'll need UV, UV2 and AnimBlend. Otherwise you'll only need UV.

    I haven't done any detailed testing of this so there may be cases that this doesn't cover.

    Sorry I've no idea about the bright spots, but the mis-matched streams may indeed be causing problems.
     
  4. sebastianzander

    sebastianzander

    Joined:
    Mar 22, 2018
    Posts:
    22
    Thank you so far. Can you give me a clue where to start? I haven't yet worked with Shader Graph but I programmed (extended and edited) two or three shaders so far. Is it possible to update the shaders that you provided and match the streams in Shader Graph or do I have to manually code this?

    As for the TANGENT stream: I do not require any normal mapping in my particles - what exactly do you mean "if the shader graph is using normal mapping?" - I don't know if it uses normal mapping. Do you even talk about the shader graph shaders that you provide?

    As for the TEXCOORD/UV stream: I assume flipbooks are this kind of sprite maps/texture atlas with multiple versions of the same particle texture. If so then I have to say yes, the dust storm examples from the Unity Particle Pack use such particle textures. I use the ParticleLitFlipbook shader now but the result is still the same - and like before the UV mapping is correct.
     
  5. djkebab

    djkebab

    Joined:
    Aug 25, 2019
    Posts:
    1
    Erh, the "Color over Lifetime" doesnt work with HDRP yet?

    I am running Unity 2019.1.11f1
    And i run HDRP 5.16.1

    And i am using HDRP/unlit material.

    But i lose control over fading via color over lifetime. Can i fade in and out another way until it's fixed?
     
  6. konsic

    konsic

    Joined:
    Oct 19, 2015
    Posts:
    799
    You need particle shader which has vertex color node.
     
    richardkettlewell likes this.
  7. Velo222

    Velo222

    Joined:
    Apr 29, 2012
    Posts:
    1,311
    I noticed in HDRP the particles will be very bright at certain camera angles and camera pitches, but then can also go completely "black" at other camera angles. What causes this? And is there a way to tell the particles or the camera not to do that?

    The particles look good at a few specific camera angles, then when I "look down" with my camera the particles go completely black and it is really unrealistic.

    I tried adding in another directional light into my scene to try to keep the particles from "going black", which helped a little bit, but still doesn't fix the problem. I know it's probably a realistic camera feature with light or something, but I want my particles to stop doing that.
     
  8. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    1,208
    Maybe setting the Normal Direction property in the renderer module will help, as it makes the lighting behave as though the billboards are spherical (approximately)
     
    Velo222 likes this.
  9. Korindian

    Korindian

    Joined:
    Jun 25, 2013
    Posts:
    447
    Is there support for fog for the HDRP particle shaders? I read in the docs that the fog node only works with LWRP/URP.
     
  10. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    1,208
    I don't know - the particle shaders are simply shader graph shaders, so it's more a question of whether it's possible to have fog via shader graph in HDRP. If the answer is yes, then fog could definitely be added to the particle shaders too. (maybe there is a checkbox in the master node settings or something - I'm admittedly not super familiar with HDRP)
     
  11. Korindian

    Korindian

    Joined:
    Jun 25, 2013
    Posts:
    447
    So there is a checkbox for "Receive Fog" in the HDRP master nodes. However, it doesn't work in all cases.

    All the included HDRP ParticleUnlit* shaders have the box checked. Receiving fog works for all of them except the "ParticleUnlit" shader. That one only receives fog if you connect a Scene Depth node or a Position node set to View, which the other shaders have.

    Not sure why receiving fog doesn't get activated for that one. Perhaps some code is not included?

    I created a bug report for it: 1192876

    Hopefully someone can take a look at it.
     
    richardkettlewell likes this.