Search Unity

  1. The 2022.1 beta is now available for testing. To find out what's new, have a look at our 2022.1 beta blog post.
    Dismiss Notice

HDRP/Lit Materials only completely white with newest update

Discussion in 'High Definition Render Pipeline' started by Digot, Jan 31, 2020.

  1. Digot

    Digot

    Joined:
    Nov 4, 2014
    Posts:
    11
    Hello!

    My Materials with the HDRP/Lit shader just render white color when it previously worked with the previous version of unity. Also creating new Materials doesn't help.
     
  2. hertz-rat

    hertz-rat

    Joined:
    Nov 3, 2019
    Posts:
    71
    ... I found my things are gray, not white; however, only if they are in shadow/facing away from the directional light, and especially if the hdri sky is enabled. If its fully lit, the colors work great.
     
  3. Ne0mega

    Ne0mega

    Joined:
    Feb 18, 2018
    Posts:
    501
    for some reason, directional light is 10,000 lux by default. try turning it down to 2.
     
  4. galaxymaxx

    galaxymaxx

    Joined:
    May 13, 2018
    Posts:
    2
    Ok, it is because of the light. I put the light to 60000 lumen and I see the color finally
     
  5. SebLagarde

    SebLagarde

    Unity Technologies

    Joined:
    Dec 30, 2015
    Posts:
    825
    Hi, It is certainly because of the default value of exposure in the project (guess it is 11 in the template). You need to tweak exposure for your need.
     
    Glurth likes this.
  6. Glurth

    Glurth

    Joined:
    Dec 29, 2014
    Posts:
    106
    It was indeed the default exposure for the project, for me. Took me a while to find it; It is at

    Edit->ProjectSettings->HDRP Default Settings->Exposure.

    It WAS set to "automatic" so I changed it to "Fixed" and set a value for "fixed exposed"- didn't test out the other options, but this got stuff displaying properly. here's a pic of the settings page upload_2020-8-2_10-0-22.png
     

    Attached Files:

    albertrosa likes this.
  7. SebLagarde

    SebLagarde

    Unity Technologies

    Joined:
    Dec 30, 2015
    Posts:
    825
    Note that you can override the default settings by creating an exposure volume in your scene. Default settings apply to whole project.
     
    albertrosa likes this.
  8. iDerp69

    iDerp69

    Joined:
    Oct 27, 2018
    Posts:
    19
    I ran into this exact problem. Interestingly, I only had a white screen in my build, but not within the Unity editor. This resolved my issue, so thank you!
     
unityunity