Search Unity

HDRP in VR - does not work

Discussion in '2018.3 Beta' started by vladibo, Nov 6, 2018.

  1. vladibo

    vladibo

    Joined:
    Jan 29, 2013
    Posts:
    36
    I am trying to follow these steps with 2018.3 beta:

    https://github.com/Unity-Technologies/ScriptableRenderPipeline/wiki/VR-in-HDRP

    However after doing all as described I am getting error

    AR/VR devices are not supported, no rendering will occur
    UnityEngine.GUIUtility:processEvent(Int32, IntPtr)


    What steps prevents this error? Do I need to use Unity alpha for that? I installed alpha but did not see HDRP there...
     
  2. rizu

    rizu

    Joined:
    Oct 8, 2013
    Posts:
    1,278
    You need latest SRP (4.1.0-preview or sources from github branch) and you do need to have relevant VR packages installed, for SteamVR, make sure you have OpenVR enabled from package manager and in the player settings. Make sure you have setup VR to use Single Pass without the instancing.

    I haven't tried the camera relative change myself, at least without it you didn't get shadows in VR, I dunno if it's related to the setting. Otherwise, VR did work on it (tested on 2018.3.0 betas).
     
    vladibo likes this.
  3. vladibo

    vladibo

    Joined:
    Jan 29, 2013
    Posts:
    36
    Thank you Rizu! I will try it today.
     
  4. rizu

    rizu

    Joined:
    Oct 8, 2013
    Posts:
    1,278
  5. demonixis

    demonixis

    Joined:
    Aug 20, 2013
    Posts:
    102
    @rizu does the eye separation is good for you? I tried VR with 4.0.1, 4.1 and 5.0 (using 2019.1a) and the eye separation is not good when testing with a Windows MR headset and SteamVR. Do you encouter the same issue?
     
  6. foster_991

    foster_991

    Joined:
    Nov 17, 2018
    Posts:
    5
    Hi. I got it to run in VR and detected vr device
    steps to take:
    Setting up unity HD for VR
    1 Install beta Unity 2018.3.0b11
    3 2 Open Hub. Create new project in HD RP (ten minutes)
    4 Window/Package Manager / HD Render Pipeline > version is 3.3.0 (preview)
    5 Click Update to 4.2.0 (preview) (takes 10-20 min)
    6 OpenVR version 1.0.2 > install
    7 Post processing> install
    8 Edit/project setting/player/xr
    9 Edit/project setting/player/xr
    turn vr on
    Sterio rendering mode single pass
    10 Project explorer/settings/HD RenderPipelineAsset
    Render Pipeline Supported Features> turn SSR off
    Support multi sample is off
    Support Lit Shader> Forward only
    Runtime debug display off
    Support MSAA off
    Turn decals off
    11 Default Frame Setting For Camera:
    FTPL for forward opaque off
    Compute light evaluation off
    Distortion off
    12 Default Frame Setting For realtime reflection:
    FTPL for forward opaque off
    Compute light evaluation off
    Distortion off
    13 Default Frame Setting For baked or camera reflection:
    FTPL for forward opaque off
    14 SRP sources from github branch
    Install git desktop https://desktop.github.com/ (win 64 bit)
    Log in. <>
    15 click Clone a Repository
    Enter
    Path <path>/GitHub
    Click Url
    Enter https://github.com/Unity-Technologies/ScriptableRenderPipeline
    (path should now say D:\vrgame\GitHub\ScriptableRenderPipeline)
    Click choose… (make sure directory opens)
    Click Clone
    … source code for ScriptableRenderPipeline downloads. One hour
    >this might be master branch (1018.9 version or later) so we need to set the right version of source
    16 Open Command prompt as administrator
    Go to <path>\GitHub\ScriptableRenderPipeline
    Git tags (list what tags are available)
    17 git checkout tags/4.2.0-preview
    18 edit local includes
    <path>/GitHub/ScriptableRenderPipeline/com.unity.render-pipelines.high-definition/Runtime
    Edit the following file:
    ShaderConfig.cs
    CameraRelativeRendering = 0,
    19 edit local includes
    ShaderConfig.cs.hlsl
    #define SHADEROPTIONS_CAMERA_RELATIVE_RENDERING (0)
    20 edit local includes
    <path>/GitHub/ScriptableRenderPipeline/com.unity.shadergraph
    ShaderConfig.cs.hlsl
    #define SHADEROPTIONS_CAMERA_RELATIVE_RENDERING (0)
    21 point in your project to your locally compiled srp
    Open Command prompt as administrator
    Go to
    D:\vrgame\project\ausTNT_2018_3b_1\Packages
    Edit manifest.json
    "com.unity.render-pipelines.high-definition": "file:/vrgame/GitHub/ScriptableRenderPipeline/com.unity.render-pipelines.high-definition",
    22 In hub open project
    Window>package manager>High Definition RP will now have a tag of [local]
    Need to recreate includes as we are using new rendering pipeine
    >edit>render pipeline>generate shader includes
    23 reload scene
    >> the first time you run the scene rendering fails. i assumed it was a cache problem. i went to a different scene and load it. then reload the scene, and it worked
     
    zeb33 and vladibo like this.
  7. vladibo

    vladibo

    Joined:
    Jan 29, 2013
    Posts:
    36
    Thank you very much Foster!!!
     
  8. vladibo

    vladibo

    Joined:
    Jan 29, 2013
    Posts:
    36
    Following those steps I can get it to run in VR but the default HDRP scene can't get to 90 frames per second. Even if I disable volume still can't get there. Also I can't see subsurface scattering. It works in the Editor (I can see the scattering) but not in game. I guess I would have to wait for the official release...
     
unityunity