Search Unity

Help Wanted HDRP doesn't recognize XR Management Systems (VR)

Discussion in 'High Definition Render Pipeline' started by Penhoat, Mar 26, 2020.

  1. Penhoat

    Penhoat

    Joined:
    Mar 2, 2020
    Posts:
    73
    Hey everyone,

    I'm using Unity 2019.3.3 + HDRP 7.1.8 and after upgrading/switching to the XR Management System for VR plugins (due to the old system being deprecated), HDRP no longer recognizes VR is enabled. This results in any form of lights, point lights, area lights, to not be visible in game (works fine in the scene of course).
     
  2. fabien-unity

    fabien-unity

    Unity Technologies

    Joined:
    Oct 17, 2018
    Posts:
    28
    Hi,
    Can you update to the latest version of HDRP (at least 7.2.1) and retry ?

    Fabien
     
  3. Penhoat

    Penhoat

    Joined:
    Mar 2, 2020
    Posts:
    73
    Last time I tried 7.2.1 it completely messed up all lighting, but I gave it a go to see if it fixed the issue.

    Now it works fine, no issues with messing up general lighting (jeej). It definitely does now recognize the new XR Management VR system, which is amazing. Unfortunately my Point lights, Area lights, etc, are still not visible in game.
     
  4. fabien-unity

    fabien-unity

    Unity Technologies

    Joined:
    Oct 17, 2018
    Posts:
    28
    Penhoat likes this.
  5. Penhoat

    Penhoat

    Joined:
    Mar 2, 2020
    Posts:
    73
    Should've upgraded to 7.3.1 straight away haha.

    Anyway this solved the issue! All lighting is visible ingame now. However I do notice a sort of (motion) blue when moving the camera/headset. I don't have motion blur on in my post processing volume, could it be that by default this is now enabled somewhere?

    Upgrading to 7.3.1 even solved some of my shader issues!
     
  6. fabien-unity

    fabien-unity

    Unity Technologies

    Joined:
    Oct 17, 2018
    Posts:
    28
    Great!
    And yes, I think motion blur is now part of the default settings. I'll discuss with the team and see if we can disable it for VR by default somehow.

    Cheers,
    Fabien
     
  7. Penhoat

    Penhoat

    Joined:
    Mar 2, 2020
    Posts:
    73
    Good to know! Any way I can manually turn it off in one of the settings?
     
  8. fabien-unity

    fabien-unity

    Unity Technologies

    Joined:
    Oct 17, 2018
    Posts:
    28
    Penhoat likes this.
  9. Penhoat

    Penhoat

    Joined:
    Mar 2, 2020
    Posts:
    73
unityunity