Search Unity

  1. New Unity Live Help updates. Check them out here!

    Dismiss Notice

HDRP auto exposure on by default and cannot find where its located to turn it off....

Discussion in 'High Definition Render Pipeline' started by sunseeker1988, Mar 21, 2020.

  1. sunseeker1988

    sunseeker1988

    Joined:
    Jul 10, 2014
    Posts:
    439
    I have upgraded to the HDRP pipeline and deleted my post process global volume and removed it from my players camera but its still on....is auto exposure on by default in HDRP and where can I turn it off at or adjust its settings? I am confused since I have not set up any post processing in HDRP yet, but it seems things are on by default.....
     
    Last edited: Mar 22, 2020
  2. rz_0lento

    rz_0lento

    Joined:
    Oct 8, 2013
    Posts:
    1,424
    Navigate to your Player Settings->HDRP Default Settings and scroll down until you get to default volume. There are some things that are preset there.

    As a side note, I don't like this approach myself at all nor does docs seem to mention it anywhere either which can for sure cause more confusion.
     
    sunseeker1988 likes this.
  3. sunseeker1988

    sunseeker1988

    Joined:
    Jul 10, 2014
    Posts:
    439
    It seems I had to add the volume and gameObject and then add override for exposure and then change to mode>fixed on the Exposure part of the volume. Super weird how to use and change Exposure as its a post processing effect you need to add Volume gameobject and then add overides for each post processing effect, BUT this is not the case with anew project and its on by default, BUT not accessible unless you add it since the only location is editing post processing effects on a Volume gameobject,. This should be fixed, and you need to add it to the Volume to even "turn it off" aka set to Fixed for the mode. Might just be an issue with Exposure but now I'm wondering what else is "on, and hidden in the background" for post processing effects.
     
unityunity