Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

HDRP All materials are white in a project view

Discussion in 'Graphics Experimental Previews' started by GiftedMamba, Mar 28, 2020.

  1. GiftedMamba

    GiftedMamba

    Joined:
    Feb 25, 2017
    Posts:
    46
    Hi all.
    For some reasons if I create any material in editor, it will be white in a project view. In the scene view everything is ok. I am using Unity 2019.3.7f1.

    Also, if I set metallic value to 1, materials previewed correct. Does anyone have any ideas?
     
  2. Blinkq

    Blinkq

    Joined:
    Apr 19, 2015
    Posts:
    21
    Same, how to configurate exposure for project view ? looking for help
     
  3. Giustitia

    Giustitia

    Joined:
    Oct 26, 2015
    Posts:
    113
    Same here, also after upgrading to 2019.3.8f1
     
  4. Giustitia

    Giustitia

    Joined:
    Oct 26, 2015
    Posts:
    113
    Just to make you know, I just realised that if you hit play/stop with scene view closed or not showed, materials are shown well (if they dont, just reimport also with scene view closed). Problems come when Unity "reloads" the thumbnails, even for a reimport or a serialization or whatever and scene view is being showed up.
     
  5. GiftedMamba

    GiftedMamba

    Joined:
    Feb 25, 2017
    Posts:
    46
    I have to close both Scene and Game view, otherwise all materials preview is white
     
  6. Giustitia

    Giustitia

    Joined:
    Oct 26, 2015
    Posts:
    113
    Normally I have no camera spawned in edit time, since I spawn it on play, so problem may be relate to both scene and game cameras
     
  7. GiftedMamba

    GiftedMamba

    Joined:
    Feb 25, 2017
    Posts:
    46
    Well. I reported this bug to Unity Technologies.

    Today I received the answer: I should upgrade my HDRP to 7.3.1 version and issue will gone.
    I checked my HDRP version. It already was 7.3.1
    So I removed HDRP package from my project completely, and then import again. It helps.

    Don't forget to make a backup of your project.
     
  8. Giustitia

    Giustitia

    Joined:
    Oct 26, 2015
    Posts:
    113
    I just figured out where the problem comes from. It's related with the Exposure from the HDRI Sky inside the Sky and Fog setting Profile assigned to the scene in the lighting tab. If exposure is set to 0, or the profile is not assigned to the scene lighting or whatever, thumbnails are correctly displayed. But obviously, we need to have an HDRI sky with correct values on exposure assigned to our scene to have a fancy enviroment. So, I guess problem come from there and it demands a fix :p
     
  9. Giustitia

    Giustitia

    Joined:
    Oct 26, 2015
    Posts:
    113
    Or to make it easier, just activate/deactivate the "Statick Lighting Sky" setting inside the lighting tab. None = thumbnails work :) HDRISky = ugly thumnbails :(
     
  10. GiftedMamba

    GiftedMamba

    Joined:
    Feb 25, 2017
    Posts:
    46
    Well, Reimporting HDRP works only while you restart project. After restarting materials preview are white again. Still looking for fix.
     
  11. Giustitia

    Giustitia

    Joined:
    Oct 26, 2015
    Posts:
    113
  12. mookanana

    mookanana

    Joined:
    Nov 12, 2013
    Posts:
    2
    HDRP white materials (only in editor, game view ok)

    i had a problem where my editor view was showing white materials, but the game view was fine.

    it seems to be an exposure problem because when i override the exposure using the camera dropdown menu (button next to 'gizmos' in editor view) it would correctly show. but of course this isn't a solution because we want to see the exposure as what it really is, and not as an override.

    after much hair pulling, i found out that by selecting window>layouts>default, this would fix my problem. this seems to be a unity bug that comes from having the editor/game view showing in different windows.
     
  13. pachermann

    pachermann

    Joined:
    Dec 18, 2013
    Posts:
    135
    This has been happening to me right now, but i produced the error becaue i imported a very old asset with enlighten baker settings and many more old crap.

    I use the LTE 2020.3.x with HDRP, this means that old unity Scene setting can reall yrip you off and the importer warns you EXPLICITLY... but you know *i thought i try what happens.

    So be carefully what you import *dumb me... The Layout reset solved the problem.

    Thank for sharing @mookanana
     
  14. MrHat

    MrHat

    Joined:
    Jan 12, 2014
    Posts:
    4
    Thanks so much for posting that- restoring default layout fixed it for me too. I too lost a bunch of hair to this one haha.
     
    Giustitia likes this.
  15. robertsofronea58

    robertsofronea58

    Joined:
    Sep 4, 2021
    Posts:
    1
    in HDRP settings switch exposure mode to "use physical camera",that is working for me
     
  16. razzraziel

    razzraziel

    Joined:
    Sep 13, 2018
    Posts:
    396
    Maybe because in your layout you have disabled this option? Try enabling it.
     
    Angelosbuf likes this.
  17. Angelosbuf

    Angelosbuf

    Joined:
    Feb 16, 2022
    Posts:
    2
    You’re screenshot saved me from becoming jobless ! Thank you !!
     
  18. Spikebor

    Spikebor

    Joined:
    May 30, 2019
    Posts:
    288
    Don't have to reimport ( that will take ages )
    Can just revert layout to default and the issue is gone.