Search Unity

HDRP 5.3.0 PPv3 Bloom blurs the whole frame

Discussion in 'Graphics Experimental Previews' started by rizu, Jan 28, 2019.

  1. Grimreaper358

    Grimreaper358

    Joined:
    Apr 8, 2013
    Posts:
    472
    @PhilSA yea the new bloom blurs the whole screen at anything above 0.1. Not sure if this will change much going forward or someone else will have to implement a bloom for a more stylized look once the PPV3 API supports custom effects.
     
  2. Grimreaper358

    Grimreaper358

    Joined:
    Apr 8, 2013
    Posts:
    472
    I didn't try to solve your issue, I just mentioned that you can use one of the other tonemapping options other than ACES to get your desired look as that one functions as it should.

    You also mentioned that
    Which No one else mentions this so could be a bug on your end if anything or maybe you use the wrong settings so I mentioned that that's not the case on my end as well as supplied images to show that.
     
  3. hatless

    hatless

    Joined:
    Dec 15, 2010
    Posts:
    26
    This might be true in theory, but it doesn't seem true in practice. Unless you have experience otherwise?

    The objects in the images were all blown out to white -- the exact issue I was trying to work around. If you can help that would be great, but restating the problem as the solution isn't helping.[/quote][/QUOTE]
     
  4. Grimreaper358

    Grimreaper358

    Joined:
    Apr 8, 2013
    Posts:
    472
    @hatless To get away from the ACES look you will have to use another tonemapping method other than ACES. In HDRP you have Neutral and Custom methods to play with as well as LUT/Lookup Table. Other than that there's nothing else right now.

    upload_2019-3-5_15-5-33.png
    upload_2019-3-5_15-6-4.png

    ACES tonemapper will always function as it does because that's what it's made to do. You will always get emissive lights going to white the brighter they are, only the surrounding glow/bloom will be the actual color. This is what the Video explained above.
     
  5. hatless

    hatless

    Joined:
    Dec 15, 2010
    Posts:
    26
    You will not believe how much I don't need this explained to me.
     
  6. PhilSA

    PhilSA

    Joined:
    Jul 11, 2013
    Posts:
    1,056
    huh... you're right! This is with 0.05 intensity and 0.8 scatter. Looks exactly the way I want

    No bloom:


    Bloom:
     
    Last edited: Mar 5, 2019
  7. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    25,206
    Yeah don't mind me explaining it much earlier 3 times :p

    In any case, @hatless Keep the intensity super low and look at hdrp lit material emission options. The control was added there for precisely these reasons of artistic control (VFX and more).
     
  8. dadude123

    dadude123

    Joined:
    Feb 26, 2014
    Posts:
    784
    Just in case you haven't already figured it out in the meantime, there's this setting here:




    "Exposure Weight" is what I'm talking about. (I know that emission intensity is what is selected in the screenshot, should have been exposure weight, sorry about that :p)

    Setting exposure weight to 0 makes it so the sphere always has the same "perceived" brightness.
    So no matter how bright or dark it is, the sphere will have the same amount of glow around it.
    Which is obviously completely unrealistic, but awesome for effects in games. Like the magic particles of my spells should always have the same "perceptual brightness" of course.