Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

Help Wanted Having Huge Trouble Retargeting

Discussion in 'Animation' started by Clydey2Times, Jul 5, 2021.

  1. Clydey2Times

    Clydey2Times

    Joined:
    Oct 24, 2017
    Posts:
    210
    Hey all,

    I purchased some bespoke mocap animations for my custom character. Unfortunately, I'm having real issues retargeting the animations to my character. I've tried my usual steps (humanoid, enforce T-pose, rotating bones), but the animations are still a mess.

    I have no idea what to do. I don't want to have wasted money on animations that will ultimately be useless. Can anyone offer some guidance?

    Here are some images of the respective avatars and how crooked the animation(s) look.

    My Avatar: MyAvatar.jpg

    Avatar from the bespoke animations:
    AnimationAvatar.jpg

    When applied to my character, the animations are crooked. Especially the head, feet and hands.
    Hands_Head.jpg

    I'd really appreciate it if anyone could help me. I'm totally at a loss. Thanks.
     
  2. Clydey2Times

    Clydey2Times

    Joined:
    Oct 24, 2017
    Posts:
    210
  3. Clydey2Times

    Clydey2Times

    Joined:
    Oct 24, 2017
    Posts:
    210
    This is a help forum, right? Because at least half of the posts end up with no replies.
     
  4. Clydey2Times

    Clydey2Times

    Joined:
    Oct 24, 2017
    Posts:
    210
    Cheers guys. Very helpful.
     
  5. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    27,841
    Check docs for correct bone naming etc. I only use generic rigs but I recall auto muscle setup is naming dependent and if your names are different you need to set that up manually. It is in the docs.
     
  6. Clydey2Times

    Clydey2Times

    Joined:
    Oct 24, 2017
    Posts:
    210
    Thanks for the reply. I'm not getting any issues with the bone names. No errors are occurring unless I switch the avatar for the animations.

    Enforcing a t-pose doesn't really help. It's clearly not the same as the t-pose on my rig. Is there a way to make the t-pose for the animation avatar identical to the one from my character's rig?
     
unityunity