Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Question grid size in scene view is messed up

Discussion in 'Editor & General Support' started by urbannomadnome, May 6, 2024.

  1. urbannomadnome

    urbannomadnome

    Joined:
    Oct 26, 2023
    Posts:
    15
    i was placing objects in scene view and my grid was not visible, but then realize that the visibility was toggled, so just activate it again, but now my grid size is huge and its not a 1 unit multiple size, is more than double but less than 3rd, mean while if i select the tile palette the grid showed is 1 unit as should be, but then if i try to move some object the grid becomes bigger again, been looking all morning and cant find a solution.
    Is there a setting to resize the grid?
    i have not moved any setting recently, but may pressed a hotkey without notice, or it could be a bug?.
    here are 2 screenshots of my scene view, one with the problem, and another one in the tile palette where it shows properly gridsizeproblem.jpg gridsizeintilepalette.jpg
     
  2. spiney199

    spiney199

    Joined:
    Feb 11, 2021
    Posts:
    8,432
    The grid that shows when you select a Grid Component (and only when you select it) is separate from the general grid overlay. The latter is used when using grid-snapping.

    Click the Dropdown next to the little grid with the magnet next to it, and you can resize your snap grid. Note I believe in your version, it's only active when your transform gizmo is in Global mode.
     
    urbannomadnome likes this.
  3. urbannomadnome

    urbannomadnome

    Joined:
    Oct 26, 2023
    Posts:
    15
    omg, it worked, thanks a lot, you're a life saver bro, now i can place objects in the proper place and not by just eye. maybe i pressed a hotkey by mistake and messed up in the first place cause i haven't moved that setting never before.
    Again, thanks! :)