Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

Graphics glitches on iPad Air

Discussion in 'iOS and tvOS' started by Recluse, Nov 27, 2013.

  1. Recluse

    Recluse

    Joined:
    May 16, 2010
    Posts:
    455
    I'm using the latest version of Unity and running up against some camera issues on iPad Air (the project displays fine on all other iPads).

    Problems:

    After a new scene has loaded (loading entirely, not using LoadLevelAdditive) graphics from the previous scene are still visible in the background.

    Objects are leaving ghosting / trails behind them, even though the camera is set to clear / depth only. Normally, this happens when camera is set to 'don't clear'.

    Has anyone else experienced issues like this on iPad Air?
     
  2. TheShane

    TheShane

    Joined:
    May 26, 2013
    Posts:
    136
    I have not, but I am interested in what the problem is. I have an iPad 4 to test on and was going to assume that the newer iPad Air wouldn't cause problems, but that may have been a foolish assumption.

    Does loading a blank scene in between help at all? Any chance of posting screen shots of the problem?
     
  3. Recluse

    Recluse

    Joined:
    May 16, 2010
    Posts:
    455
    This is a project I'm helping a client with - unfortunately they won't give me an iPad Air so it's hard to test. I'll have to get the client's permission before I can upload screens too.

    At the moment, I'm making changes and sending the build to be tested remotely, which you can imagine is tedious.

    It looks as if either:

    A) it's an issue involving multiple cameras
    B) it's an issue involving camera view distance being too great (+1000 meters).

    I'll let you know what I find out.
     
  4. Recluse

    Recluse

    Joined:
    May 16, 2010
    Posts:
    455
    Due to the build being tested remotely I'm not able to provide any detailed info, but it looks as if on iPad Air there is a problem with using multiple cameras / multiple GUILayers.

    The app in question has a camera (depth -10), which shows a full-screen GUI texture as a background. Above this (depth 0) is the main camera, set to clear depth only, with another GUI layer for score, buttons etc.

    Removing the lower camera fixed the issue of game objects leaving trails behind them, as if they were being drawn without being cleared.

    I can't be the only person who has experienced visual discrepancies with builds on iPad Air. I read somewhere else on the forum, somebody was having issues with their skybox on iPad Air. Anyone else?
     
  5. MHD Salka

    MHD Salka

    Joined:
    Mar 19, 2013
    Posts:
    72
    I'm getting serious fps drops on ipad air.....on ipad 4 the app runs at consistent 60fps......on ipad air it runs at 60 fps BUT with fps drops down to 19-24 !!!
     
    Last edited: Dec 12, 2013
  6. derkoi

    derkoi

    Joined:
    Jul 3, 2012
    Posts:
    2,087
    My app has this issue on iPad Air and iPhone 5s and I don't have either devices to test on, although I did assume it was because of a don't clear flag on my gui camera.
     
  7. DanRP

    DanRP

    Joined:
    May 26, 2013
    Posts:
    18
    I'm having the same issue with my latest Unity game.

    Here's what's happening for me: When my app loads a new scene, I see a "screenshot" of an arbitrary previous state of the app in the background instead of an expected black background.

    I checked my Camera settings in my scenes and they were set to:
    Clear Flags: Skybox
    Background (Color): Black with an alpha of 5

    I thought that maybe the alpha not being set to the max was the problem, but this issue still persists even when I set the alpha to 255. I also set the Clear Flags setting to "Solid Color", but that didn't fix it either.

    My game only uses one camera, so it's not a multi-camera issue for me.


    Any ideas?


    Dan
     
  8. DanRP

    DanRP

    Joined:
    May 26, 2013
    Posts:
    18
    UPDATE:
    I think I've fixed the problem for my app. Looking through my code, I found that, during the transition from one scene to another, I was disabling the main camera about a second or two before the next scene loaded. With the camera was disabled, I guess some "old graphics" became visible somehow.

    Note: this behavior only happened on my new iPad Air and not my other older iPads or iPhones. Be sure to test you app on an iPad Air before you release...


    Dan
     
  9. mhobbs_GTDC

    mhobbs_GTDC

    Joined:
    Feb 6, 2014
    Posts:
    6
    @Recluse Did you ever find a proper solution to this issue?

    I'm having the exact same issue with an iPad Mini 2 (same A7 chip as the first iPad Air).

    2 Cameras, 1 for skybox set at -2 and the main at -1. Instead of the skybox, it's just showing the top half of the Unity logo (which I assume is the previous image in thew buffer).

    Setting the skybox to the main camera resolves the skybox issue, but causes other issues for me (which I why I did the 2 camera solution in the first place).

    Only happening on 2 A7 devices I have (air and mini 2), not happening on Mini1.

    -Hobsie
     
  10. Shlippy

    Shlippy

    Joined:
    Jun 19, 2015
    Posts:
    1
    Anyone ever have any luck solving this?
     
unityunity