Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.

    Read our full announcement for more information and let us know if you have any questions.

GPU Skinning broken with OpenGLES3 Daydream (causes render artifacts) on 2018.3

Discussion in 'Daydream' started by Xarbrough, Jan 10, 2019.

  1. Xarbrough


    Dec 11, 2014
    I'm wondering if anyone has had similar issues and maybe found a workaround: We've upgraded our project to Unity 2018.3 and now have strange render artifacts and glitches, which look like this:

    Basically, all textures (including render textures) are garbled and flicker in wild colors as soon as a certain number of SkinnedMeshRenderers are present in the scene.

    This happens when:
    • SkinnedMeshRender count is above a certain number (approx. 40 instances)
    • GPU Skinning is enabled
    • Only Unity 2018.3 (2018.2 works fine)
    I've investigated quite a while to rule out other influences and only found the actual skinning to cause the issue. In my reproduction project there are no other textures or special objects, only SkinnedMeshRenderers without animations. In my test case I spawn skinned meshes in an empty scene. At the start, everythings works fine, then I spawn more instances and as soon as their count is roughly at 40, the flickering starts. To me, this looks like GPU Skinning is writing data to some vertex buffer and other shaders are reading from the same data or some similar effect.

    I can work around the issue by disabling GPU Skinning in the PlayerSettings, but for our current project it is basically essential to use the option because of performance limitations. Additionally, we would like to upgrade to 2018.3 because there are other unrelated performance improvements which we would like to benefit from.

    I've filed bug Case 1109597, but since it may take some time to resolve, I wanted to hear if anyone from the community knows a possible solution in the meantime. Thank you!
    Last edited: Jan 11, 2019
  2. ThatDarnCat


    Unity Technologies

    Jan 4, 2017
    Hi Xarbrough,

    Thank you for bringing this to our attention. We've managed to reproduce the issue you are seeing and our developers are investigating.
  3. Xarbrough


    Dec 11, 2014
    That’s great news, thank you!
  4. RMGK


    Sep 30, 2011
    Having the same issue using Samsung S7, running Android 8 using Unity 2018.3.3.
  5. isidro02139


    Jul 31, 2012
    Dear @ThatDarnCat any updates on this issue? I searched for case 1109597 but could not find it in the Unity Issue Tracker. We are facing this after upgrading a 2017.4 project to 2018.4, would be great if we could keep GPU Skinning enabled for performance reasons...