Search Unity

Googleplay 64bit console warning

Discussion in 'Editor & General Support' started by Lethn, May 5, 2019.

  1. CadenJO

    CadenJO

    Joined:
    Dec 9, 2017
    Posts:
    1
    I had this same problem, and after a few hours I tried disabling x86 on Unity as it was depreciated. It worked!
     
  2. 5argon

    5argon

    Joined:
    Jun 10, 2013
    Posts:
    1,431
  3. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    6,482
    You've followed the directions here, and you still get the problem?
     
  4. John3D

    John3D

    Joined:
    Mar 7, 2014
    Posts:
    401
    Hi all,

    I tried to post an update on Google Play using Unity 5.6.6 and I get this error
    Any tips pls?



    Thanks!
    Code (CSharp):
    1. Error
    2.  
    3. This release is not compliant with the Google Play 64-bit requirement
    4.  
    5. The following APKs or App Bundles are available to 64-bit devices, but they only have 32-bit native code: 8.
    6.  
    7. Include 64-bit and 32-bit native code in your app. Use the Android App Bundle publishing format to automatically ensure that each device architecture receives only the native code it needs. This avoids increasing the overall size of your app.
     
    Last edited: Aug 27, 2019
  5. Vdemon5

    Vdemon5

    Joined:
    Dec 5, 2018
    Posts:
    1
    Hi -

    I'm trying to submit my app's apk/aab into the play console but I keep getting the 64 bit error message.

    I'm using unity 2018.3.11f1
    vuforia for ar
    have all the necessary ndks for 64 bit
    checked off ARMv7 - ARM64 - x86 (when I uncheck x86 I'm unable to build - I get 2-3 error messages.)
    scripting backend IL2CPP
    min. api android 5.0 'Lollipop" api level 21
    target api level android 9.0 Pie api level 28

    Here's a link that I used to help me configure my build

    https://medium.com/@leonard.lin.200...-for-googles-64-bit-requirements-bb6ece4e57e6

    Any and all info would be greatly appreciate.
     
  6. xuan_celestial

    xuan_celestial

    Joined:
    Jul 17, 2018
    Posts:
    8
    in my case, I am using Unity 2018.3.7f1, after change the API compatibility level from .NET Standard 2.0 to .NET 4.x then my error is gone, my setting :

    -Scripting Runtime version .NET 4.x Equivalent
    -Scripting backend IL2CPP
    -API Compatibility level .NET 4.x
    -Checked off x86
     
  7. cafekd2186

    cafekd2186

    Joined:
    Sep 26, 2014
    Posts:
    1
    Hello.
    It ok when removing x86.
    I removed it and it's ok for me
    Thanks
     
  8. shweta-unity

    shweta-unity

    Joined:
    Nov 23, 2016
    Posts:
    6
  9. SpaceRay

    SpaceRay

    Joined:
    Feb 26, 2014
    Posts:
    391
    Yes, Thanks very much, I have seen that removing the X86 option now it is allowed to publish the game in Google play and I have seen again the error message that appears on the first post

    Unity only supports 32bit X86, because if it would be 64 bit, it would be X86_64 as shown on google help

    https://developer.android.com/distribute/best-practices/develop/64-bit

    For the ARM architecture, the 32-bit libraries are located in armeabi-v7a. The 64-bit equivalent is arm64-v8a.

    For the x86 architecture, look for x86 for 32-bit and x86_64 for 64-bit.

    There is no x86 64 bit option available in Unity and is deprecated
     
  10. David_Reco

    David_Reco

    Joined:
    Sep 6, 2019
    Posts:
    1
    HERE ARE THE STEPS:
    1) Make sure to download the android NDK bundle r16b, extract the zip file, and point to its location in the preferences window in unity (under the "Edit" menu).
    2) Go to the "Player settings", choose the "Other settings" panel and do the following:
    - change the compression method to IL2CPP.
    - under the target architectures check "ARMv7" and "ARM64" and uncheck "x86 (deprecated)".
    3) Go to the "Build settings" and check "Build App Bundle (Google Play)".
    4) Bulid the project and upload the resulting .aap file to Google Play.
    5) Enjoy! :)
     
    Miguel_LZ likes this.
  11. SharksInteractive

    SharksInteractive

    Joined:
    Jan 27, 2018
    Posts:
    5

    For any who this would help (This was written right before I tried the working method) having an issue here, I've selected IL2CPP as my scripting backend ticked all the boxes under target architectures reinstalled the latest version of Unity and android SDK and NDK, updated to the latest version of Android Studio, enabled building android app bundle and yet when I build the app and try to upload the .aab to google play I (Still) get the error that it supports 64 bit but uses 32-bit native code. I'm not quite sure what I'm doing wrong? The answer? I also got this weird notification that my app now required the wifi multicast permission. Upon looking it up I found out unity 2019.2 comes pre-installed with multiplayer hlapi which was doing that! Upon uninstalling and building I no longer had the wifi multicast permission, and most importantly the error was gone!
     
  12. smithmj5

    smithmj5

    Joined:
    May 24, 2013
    Posts:
    106
    Are you checking the box for "x86" under Target Architectures? If so, that's probably why you're getting the error about 64-bit and using 32-bit code.

    x86 is 32-bit. There is a 64-bit equivalent, x86_64, but Unity never supported it, and after Unity 2019.2 they are removing x86 completely.

    You should only be checking the boxes for ARMv7 and ARM64.
     
  13. atifseYsU2_3

    atifseYsU2_3

    Joined:
    Feb 24, 2017
    Posts:
    2
    I do these five but still I take same error .