Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

GLES 2.0 compatible version of the ARKit plugin

Discussion in 'AR' started by marcipw, Dec 5, 2017.

  1. marcipw

    marcipw

    Joined:
    Apr 18, 2013
    Posts:
    239
    Hi guys,
    I saw a branch on bitbucket that enabled the Unity ARKit plugin to work with GLES 2.0.
    I can not seem to get it to work though and I need it for a project that uses also uses EasyAR for image tracking.
    I am a complete Bit / Git noob and have no idea how to download branches to work with the main repository.

    The regular plugin will work with EasyAR if I set the target to GLES 2 (which is the only thing EasyAR supports unfortunately) but the ARKit Camera feed just displays as green.

    Regular ARKit from Bitbucket works fine on its own on my iPad Pro 2017 as does the version from the asset store. I would really, really love any pointers.

    Many Thanks in advance.
     
  2. marcipw

    marcipw

    Joined:
    Apr 18, 2013
    Posts:
    239
  3. marcipw

    marcipw

    Joined:
    Apr 18, 2013
    Posts:
    239
    Hey guys! Sorry to be a pest but is there any word on this at all? Is anyone else interested? EasyAR is a pretty cool (and free) target based AR SDK and It would be useful to have this and ARKit running in the same app.