Search Unity

Question Getting some weird blocky effects after baking lights SOLVED

Discussion in 'High Definition Render Pipeline' started by Calum, Nov 28, 2019.

  1. Calum

    Calum

    Joined:
    Mar 14, 2015
    Posts:
    45
    Hi there,

    I'm having a strange problem with my bakes. There's a couple of areas of the room I've made where the bake creates these blocky, angular shapes.

    I tried mucking around with the settings for a few days now and can't seem to get rid of them.

    Unity Ver - 2019.2.11f1 HDRP Ver - 6.9.2

    Any help with this would be greatly appreciated! Thanks in advance for looking.

    Calum
     

    Attached Files:

  2. Bordeaux_Fox

    Bordeaux_Fox

    Joined:
    Nov 14, 2018
    Posts:
    589
    Try to increase the lightmap size to 2048 at least. Also indoor scenes need far higher settings to look good. I recommend at least 5000 samples.

    For what I saw on the Unity blog posts, they using a lightmap size of 4096 and also very high sample rate to achieve the best results for architecture scenes.

    Also turn on the option "Dithering" on the camera component.

    Hope that helps.
     
    Calum likes this.
  3. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    11,791
    None of that will help.

    Start a bake and switch to Texel Validity view in scene editor. I bet the problem areas will show red.

    You probably have open backfaces somewhere. If it's intentional, mark those materials as "Double Sided Global Illumination".
     
    Calum likes this.
  4. Calum

    Calum

    Joined:
    Mar 14, 2015
    Posts:
    45
    Thanks for the replies guys, I'll start digging around those things!

    EDIT: Texel Validity seems to show no errors (or anything in red)
     
    Last edited: Nov 29, 2019
  5. Calum

    Calum

    Joined:
    Mar 14, 2015
    Posts:
    45
    Okay, so the double-sided material thing was the problem! :)