Search Unity

Getting Quest Link to work in Unity

Discussion in 'AR/VR (XR) Discussion' started by adamz, Nov 20, 2019.

  1. adamz

    adamz

    Joined:
    Jul 18, 2007
    Posts:
    974
    ~~ UPDATED ~~

    Good news... with Link you're now able to "Play" your scene WITHOUT building the apk!

    1) Have the Oculus Software on the Quest updated to the latest.
    2) Install the latest Oculus desktop software and have that updated to the latest.
    3) Install the latest version of Unity (I did not install the Beta).
    4) Create a new 3D project - not HDRP or LWRP/URP.
    5) Go to Build settings, enable Android with the ASTC texture compression.
    6) Go to Player Settings > Other, enable Android KitKat 4.4, remove Vulkan under rendering.
    7)Go to Player Settings > XR, enable Oculus.
    8) Install 'Oculus Desktop' from the Package Manager if you want to run the scene when you press the Play Button.
    9) Plug in the Quest via USB, put on the Quest and accept the Link Beta popup (you should see the Rift home-room, not Quest's), press the Play button in Unity, put your Quest back on and it should all work.
    10) That's it!!

    If you're getting a warning in the Oculus Desktop software that "A Quest software update is required for Oculus Link (Beta). Install the update from the About section of Settings in your headset." and you CAN'T update your Quest because it's already at the latest version, you need to go into the Oculus Desktop app: 'Settings > Beta' and TURN OFF the Public Test Channel. That should fix your problem.

    Happy Questing!

    ---------

    P.S. if you're just building an apk to the Quest, don't accept the 'Link Beta' popup, and accept the 'Allow Quest to Access Your Data' popup. You should be able to build to your Quest and it should auto load your app in the Quest if you follow the above steps. Sometimes it doesn't work for me right away, so I needed to unplug the USB to the Quest, re-plugin the USB or reboot the Quest, decline/accept the popups again, then rebuild.

    If you're trying to find your build on your Quest it's under: 'Library > Unknown Sources'.
     
    Last edited: Feb 2, 2020
  2. doctor_di

    doctor_di

    Joined:
    Jan 19, 2019
    Posts:
    3
    Unity Play mode has not worked for me yet, not even with out of the box examples and I have the Oculus recommended cable. My cable works for Link and playing Rift games, but no luck on Unity Play mode. So sick of troubleshooting Unity builds, I'm headed over to check out Unreal to build for the Quest. This is bull.
     
  3. adamz

    adamz

    Joined:
    Jul 18, 2007
    Posts:
    974
    What version of Unity are you using? I'm running the latest Unity version, and have the latest Oculus software app on my PC. Once you configure your Player settings in Unity by enabling VR and selecting Oculus, it should work. Once you plugin your Quest using the USB cable, the Oculus App should launch and load your scene. If it doesn't, try starting the Oculus app, and see if the Rift home area loads (not the Quest home area). If it does, then try pressing the Play button on your scene.
     
  4. Evan-Greenwood

    Evan-Greenwood

    Joined:
    Aug 6, 2008
    Posts:
    97
    This also doesn't "just work" for me. The Oculus Link app starts running in my quest when I plug it in (and enable it), but when I hit play in Unity nothing happens.

    Is this a very latest version of Unity thing? I'm running 2019.2.8 ...?

    I'm not getting any error messages and I can't see anywhere in the Oculus App where it would tell me if this feature can be supported or cannot be supported.

    I'm going to upgrade to a more recent version of Unity and see....
     
  5. olejuer

    olejuer

    Joined:
    Dec 1, 2014
    Posts:
    85
    For me, this is working after a bit of effort. I ran into some trouble with inconsistent versions of the Quest software and Oculus software on my machine. Make sure, those are aligned. It might require you to opt in or opt out of the public test channel of the Oculus software.
    I'd also suggest to unplug other VR devices you might have attached to your PC just in case.
    I would think that the Unity side of this does not really care if it is a Quest or Rift you have attached. Shouldn't the Oculus app be an abstraction layer for this?
    Also, and this is important, if you develop for Oculus Quest using Link, you should still build and test an apk frequently. There are differences and you want to catch issues early! Especially when it comes to URP, or rendering in general for that matter, some things just do not work in android builds.
     
  6. Deleted User

    Deleted User

    Guest

    After a couple days finally got it working (although to be fair I am using a 1060 which doesn't appear to be supported). Using the oculus basic scenes still don't work but VRTK example scenes are. Also adding the Desktop panel method did not work for me. I simple stay in the lobby area and hit play on one of the VRTK scenes and that works right now.
     
  7. TheCircadian

    TheCircadian

    Joined:
    Jul 30, 2016
    Posts:
    7
    For me Installing the Oculus Desktop did the trick!

    I think between the "Enable XR Settings" in Player Settings, and Installing the "Oculus Integration" from the Assets Store, the "Oculus - Android" package is automatically installed, although there's another package for "Oculus - Desktop" that doesn't automatically install.

    Thanks!
     
    adamz and fuzzy3d like this.
  8. mgolino3

    mgolino3

    Joined:
    Mar 15, 2019
    Posts:
    2

    I was struggling with this today after just getting a link cable. The missing piece was the "Oculus Desktop" package. Thank you so much for posting this @adamz this is the only place I found that talked about needing that since I previously just had the Oculus Android package.

    THANK YOU. And good luck to anyone else that stumbles on this post in the future!
     
    adamz likes this.
  9. adamz

    adamz

    Joined:
    Jul 18, 2007
    Posts:
    974
    You're welcome. Glad you got it working.
     
  10. adamz

    adamz

    Joined:
    Jul 18, 2007
    Posts:
    974
    I updated the steps at the top of the thread to make it easy for people to find them. Any problems let me know and I'll try to help.
     
  11. mlongley_fb

    mlongley_fb

    Joined:
    Aug 21, 2019
    Posts:
    5
    Hello!

    I followed the steps above and still getting to response from the Quest..

    My home scene in the Quest was the Quest Home and not the Rift Home..

    I did get this error though..

    "Virtual Reality SDK Oculus failed to initialize.
    Will attempt to enable Oculus instead."

    Oculus then didn't work so it then jumped to OpenVR, which then did not work, so then it looks like it jumped to "None".

    This scene did work for Rift (and Quest Link when built) back when it was set to Standalone as it's platform..
     
    Thoronnim_Crystalia likes this.
  12. mlongley_fb

    mlongley_fb

    Joined:
    Aug 21, 2019
    Posts:
    5
    I'm also using Unity 2019.2.17f1 :)
     
  13. adamz

    adamz

    Joined:
    Jul 18, 2007
    Posts:
    974
    If you have the latest version of the Oculus Desktop software installed on your PC and your Quest is up-to-date, when you plugin the USB do you get a popup asking you to enable Link? If you do and hit accept, you should see the Oculus Rift home room. If that's working then at least you know the desktop software is communicating with your Quest.

    As to your SDK failing, I would try to create a new project and follow the steps at the top of the thread. Other than that suggestion, I'm not sure what else I can help you with. I'm just a guy who's developing a Quest app in my free time, so I just wanted to post some of my steps to get it working as well as solutions to the problems that I ran into. :)

    I know v13 update for the Quest is rolling out this week, so maybe that will help too...

    Good luck!
     
  14. jkh0208

    jkh0208

    Joined:
    Aug 23, 2019
    Posts:
    15
    Oculus Link was working great for me previously for my voice recognition VR app, but after update 12 came out for the Quest, the mic stopped working. Version 13 didn't seem to fix it either.
     
  15. Ostwind

    Ostwind

    Joined:
    Mar 22, 2011
    Posts:
    2,804
    It was mentioned by Oculus dev back when v12 came out that mic has been disabled on purpose and will be awhile before it will be coming back.
     
  16. jkh0208

    jkh0208

    Joined:
    Aug 23, 2019
    Posts:
    15
    Ah, I must have missed that in the log. I can't seem to find a way to downgrade back to v11, which is really unfortunate since I bought this device specifically for this purpose and my thesis capstone is suppose to be presented next month, and my thesis advisor already paid for travel for this presentation.
     
  17. Ostwind

    Ostwind

    Joined:
    Mar 22, 2011
    Posts:
    2,804
    You can use a regular PC mic as you are near the computer anyways due the cable.
     
  18. jiraphatK

    jiraphatK

    Joined:
    Sep 29, 2018
    Posts:
    15
    Currently, If I'm not able to use Post-Processing with Oculus Link. the play screen just turn grey.
    Is there a way around this?

    Edit- the build apk worked fine
     
  19. Mazzeman

    Mazzeman

    Joined:
    Mar 3, 2017
    Posts:
    6
    Followed the steps above, have tried different versions of 2019.
    Now I'm running 2019.2.21f and I cannot run Oculus link, I'm getting the following errors:

    upload_2020-2-20_8-59-36.png

    Claiming I don't have the SDK installed. Anyone encountering the same issues?
     
    Thoronnim_Crystalia likes this.
  20. Thoronnim_Crystalia

    Thoronnim_Crystalia

    Joined:
    Jan 24, 2017
    Posts:
    25
    Yes, I'm facing the same problem since two days... I tried tens of different solutions, but nothing solves it!
     
  21. ugur

    ugur

    Joined:
    Jun 3, 2008
    Posts:
    683
    this could happen for a few different reasons, but if in your Unity project all worked fine before (so you have all the needed things installed/enabled) and then it suddenly by itself does not work anymore, then a common issue in my experience is that there is an Oculus update and you first have to install that in the oculus desktop app to have things work again in Unity.
    When you open the Oculus desktop app you can see in the updates section if there is an update and install it.
    It also there in the release notes states some compatibility info sometimes.
    Right now one needs a certain version on desktop to match a certain OS update version on the Quest.
    Sometimes it is the pre release channel release, sometimes the stable channel release.
    Check the release notes in the updates in the oculus desktop app to go sure you have the correct combination of things installed in the oculus desktop app for that particular OS version on your Quest.
     
  22. Follet

    Follet

    Joined:
    May 18, 2018
    Posts:
    21
  23. Fangh

    Fangh

    Joined:
    Apr 19, 2013
    Posts:
    42
    If you are using Unity 2019.3 you do not need the step 8 "Install 'Oculus Desktop' from the Package Manager."

    But you need to activate the XR Plugin Oculus Loader for PC
    upload_2020-2-28_12-14-39.png
     
    VincentSerpico and xtr33me like this.
  24. fuzzy3d

    fuzzy3d

    Joined:
    Jun 17, 2009
    Posts:
    85
    Hi, testing Oculus Quest Link on HP Omen notebook (RTX 2070 Max-Q):
    upload_2020-2-29_17-51-12.png

    Oculus debug tool:
    upload_2020-2-29_17-54-38.png

    PC:
    Oculus App Version 14.0.0.140.710 (14.0.0.140.710)

    Cable:
    2 meters from Axagon:
    https://www.axagon.eu/en/produkty/bucm3-amxxg
    + 5 meters extension cord from this set:
    https://www.amazon.de/gp/product/B083NTSVLH/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
    3m cable from this set is not working, 5m extension yes, so I have now 2+ 5m Link cable.

    Resolution could be better (compared to HTC Vive Pro), but at least I have no problem with AA :)
     

    Attached Files:

    Last edited: Mar 1, 2020
  25. stippy

    stippy

    Joined:
    Mar 1, 2020
    Posts:
    9
    Would mean then:
    1) Have the Oculus Software on the Quest updated to the latest.
    2) Install the latest Oculus desktop software and have that updated to the latest.
    3) Install the latest version of Unity (I did not install the Beta).
    4) Create a new 3D project - not HDRP or LWRP/URP.
    5) Go to Build settings, enable Android with the ASTC texture compression.
    6) Go to Player Settings > Other, enable Android KitKat 4.4, remove Vulkan under rendering.
    7) Activate the XR Plugin Oculus Loader for PC
    8) Under XR Plugin Management -> Oculus: click the create button and set the Stereo Rendering Mode to ???
    9) Plug in the Quest via USB, put on the Quest and accept the Link Beta popup (you should see the Rift home-room, not Quest's), press the Play button in Unity, put your Quest back on and it should all work.

    ---> Apparently I am missing a step, as pressing play button just does nothing but starting the static camera in Unity and not showing anything (apart from oculus link home) on the quest side. Building the .apk and running works. Oculus Home (PC) is version 14 and quest is also version 14, so should be up to date.
     
  26. Fangh

    Fangh

    Joined:
    Apr 19, 2013
    Posts:
    42
    @stippy at step (8) you should activate it for PC & for android. The both of it.

    In my experience, the step (5) is not required
     
  27. stippy

    stippy

    Joined:
    Mar 1, 2020
    Posts:
    9
    Ah, that was my mistake. Did only do it for PC, not Andorid too. Thank you very much, works like a charm now =)
     
    Fangh likes this.
  28. danrayrollan98

    danrayrollan98

    Joined:
    Jul 4, 2019
    Posts:
    1

    How did you enable the Oculus Link Cable in 2019.3 ?? I'm using a new framework the XR interaction toolkit
     
  29. a436t4ataf

    a436t4ataf

    Joined:
    May 19, 2013
    Posts:
    589
    Oculus Desktop/Quest v14 with Unity 2019.3.3 requires very few steps now. I had a week of back and forth with Oculus support, but eventually got it working today.

    Pre-amble (things that can prevent it working and will give you NO error message (I learned the hard way)...
    1. (Lesson learned): Oculus currently has no software detection for "is this a USB3 cable or not"? So ... Make sure you have a USB3 cable (not USB2 - they look identical, and if the vendor doesn't say USB3 specifically, it's USB2). I had a broken USB3 cable, and a USB2 cable that was marked as USB3 (argh!). The main giveaway is the quoted transfer speed: 480Mbps = USB2, 5Gbps = USB3 (for the cable, not the port!)
    2. Check you have latest: motherboard BIOS, Windows10 update (v1909 today), USB3 drivers (most people have AMisMedia drivers - windows should show them as AmisMedia31 in Device Manager)
    3. Oculus Desktop: v14
    4. Quest: v14 (should have rolled out to everyone by now)
    5. If it's all working, run Desktop, go to Devices > Setup Quest ... then plugin Quest, put it on your head and you should automatically get a popup asking about Link. If you do not - if you need to manually go into Quest settings to enable Link - then Link is probably broken / not going to work (I found as soon as I had a decent cable, the Link popup came automatically, didn't need to try manually enabling it any more (v14 Quest onwards))

    Upgrade a non-VR project / Create new VR project. Start with Unity2019.3.3 - any non-VR project works fine (I tested with a Unity 5.x project that has been upgraded > 2017 > 2018 > 2019):
    1. Open Edit > Project Settings .. then from Project Settings:
      1. XR Plugin Management > Install
      2. XR Plugin Management > Plugin Providers > + > Oculus Loader
      3. XR Plugin Management > Input Helpers > Install Legacy Input Helpers
      4. XR Plugin Management > XR Tracking > "Add Tracked Pose to ..." (or do this manually in your Hierarchy)
      5. (optional - not needed to get Play working, but you'll want to do it eventually) XR Plugin Management > Oculus > Create
    2. Oculus Desktop > Settings > General > Unknown Sources > Enable
    3. Hit play in Unity
    NB: you don't need to touch the Android settings, or build settings, at all ... you'll need those eventually in order to make a build, but just to develop and test with Play mode? Not needed, works fine without.
     
  30. xtr33me

    xtr33me

    Joined:
    Nov 2, 2011
    Posts:
    88
    OMG! I have been seriously trying to figure this out off and on for a week now with the new XR Management. I couldn't get the ability to play in the Quest via the Unity play button and it now works! Thanks soooo much.
     
    Fangh likes this.
  31. VincentSerpico

    VincentSerpico

    Joined:
    May 15, 2018
    Posts:
    1
    THANK YOU!
     
    Fangh likes this.
unityunity